NetBackup catalog backup excludes transaction log backup images for Oracle and SQL-Server Intelligent Policies

Article: 100047410
Last Published: 2020-04-08
Ratings: 0 1
Product(s): Appliances, NetBackup

Problem

The NetBackup Catalog Backup will skip some new image file types. If the NetBackup Catalog Backup is recovered in a Disaster Recovery (DR) environment, those affected file types will not be available for restore. The affected image file types are those created by transaction log schedules during backups performed by Oracle Intelligent Policy (OIP) or Microsoft SQL-Server Intelligent Policy (SIP).

Versions Affected

NetBackup 8.2 GA and earlier

Error Message

There are no visible errors.

During the catalog backup, the bpbkar debug log would show that each *_TLOG.f file is being skipped.

If that NetBackup Catalog backup is used to do a DR catalog recovery and the Oracle or SQL-Server IP clients are browsed for restore, the NetBackup Microsoft SQL Server Client GUI (dbbackup.exe) would not display all of the expected backups.

Cause

These backup schedule types create backup image files with a name format that is different from other backups.  That format is not included in the in the NeBackup 8.2 and earlier catalog backups.

Solution

To prevent future catalog backups from skipping the transaction log backup image .f files, contact NetBackup Technical Support to obtain the fix for the version of NetBackup being used.

Install the appropriate fix, then do a full catalog backup.

NetBackup 8.1: Fix associated with Etrack 3999491

NetBackup 8.1.1: Fix associated with Etrack 3999490

NetBackup 8.1.2: Fix associated with Etrack 3997818

NetBackup 8.2: Fix associated with Etrack 3996459 Version 2

Workaround:

If the DR recovery has been done using one of the affected catalog backup images, the following steps will allow the Oracle and SQL-Server Intelligent Policy restores to be completed successfully.

Identify the affected images. You can identify which images exist without the corresponding .f files by using the bpcatlist command with the flags -offline and -sched-type TLOG.  These can be combined with additional filters like client, policy, and date range.

bpcatlist -offline -sched-type TLOG

Note: The image will not have a files file if it appears in the bpcatarc -offline output.  If the image has a non-zero catarc id, the files file is archived and can be restored using the normal bpcatres process.

Expire the affected images with the -nodelete option

bpexpdate -nodelete -d 0 -backupid <backupid>

Do phase 1 and Phase 2 import of the affected images to re-buld the image .f files.
bpimport -create_db_info <storage unit info>
bpimport -backupid <backupid>

A patch has been made available for this issue. This patch has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix. Please contact Veritas Technical Support to obtain this patch.

Was this content helpful?