Problem
NetBackup client is unable to obtain a certificate from the master server.
Error Message
nbcertcmd: The -getCertificate operation failed for server <master server name>.
EXIT STATUS 5954: The host name could not be resolved to the requesting host's IP address.
The error can be translated as the primary (formerly known as master server) cannot resolve the hostname of the host executing the nbcertcmd command to the IP address on the inbound connection.
Cause
This problem can occur if the Primary server is unable to resolve the client's host name to its correct IP address either due to a lack of a DNS entry in the DNS server the Primary server is configured to use
-OR-
If this is an existing client that has had a operating system host name change but the NetBackup client software CLIENT_CONFIG value points to the old name.
Example:
On the client, when the nbcertcmd -getcertificate command is issued, we see:
# nbcertcmd -getcertificatenbcertcmd: The -getCertificate operation failed for server nbmaster1.
EXIT STATUS 5954: The host name could not be resolved to the requesting host's IP address.
On the master server, we see that hostname lookup for the client (nbclient1) fails with status 48 (client host name could not be found).
# bpclntcmd -hn nbclient1client hostname could not be found
alter client: nbclient1 : not found. (48)
Example of nslookup on the Master server failing to resolve the client hostname to an IP address:
# nslookup nbclient1** server can't find nbclient1: NXDOMAIN
Solution
Correct name resolution on the master, such that it properly resolves the client's host name (as it appears in the backup policy Clients list) to its correct IP address, forward and reverse.
May need to confirm the client name on the client itself with commands:
- OS command hostname:
# hostname
- bpclntcmd command in <install_path>\NetBackup\bin:
# bpclntcmd -self