Problem
While performing an Enterprise Vault Search (EVS) from within Outlook for a specific user, a script error is received.
Error Message
Below is the series of errors seen in sequence which reveal themselves once the Yes button is clicked to acknowledge the choice to proceed:
Script Error
! An error has occurred in the script on this page
Line: 119
Char: 35
Error: Expected ';'
Code: 0
URL: https://everver1.ev.local/EnterpriseVault/search/shell.aspx?
server=EXCHSRV&mbx=SMTP:user1@ev.local&vaultid=1344
0237A1A0EEF45AA585C107C65DE81110000evserver1&NA
Do you want to continue running scripts on this page?
[Yes][No]
Script Error
! An error has occurred in the script on this page
Line: 4
Char: 439431
Error: 'sidebarSettingHide' is unidentified
Code: 0
URL: https://everver1.ev.local/EnterpriseVault/search/Scripts/EV
S.min.ja?ver=12.1.0.1424
Do you want to continue running scripts on this page?
[Yes][No]
Script Error
! An error has occurred in the script on this page
Line: 4
Char: 58369
Error: 'gridMaxRecordsAtATimeForNon/E' is unidentified
Code: 0
URL: https://everver1.ev.local/EnterpriseVault/search/Scripts/EV
S.min.ja?ver=12.1.0.1424
Do you want to continue running scripts on this page?
[Yes][No]
Cause:
This issue is caused if the Display name of the mailbox in Exchange includes a special character such as an apostrophe / single quote (') or double quote (") (example: O"Corner)
Solution:
- Remove the special character from the affected user's display name on the Exchange server through a tool such as Active Directory Users and Computers.
- From the Enterprise Administration Vault console, run a synchronization from the Exchange Mailbox Archiving Task Properties' Synchronization tab.
- Close and reopen Outlook on the client.
- Run the following SQL query to verify the ExchangeMailboxEntry table entry for the account is updated in the EnterpriseVaultDirectory database:
USE EnterpriseVaultDirectory;
GO
SELECT *
FROM ExchangeMailboxEntry
WHERE mbxalias = 'useralias';
Note: Replace useralias with the alias of the user account linked to the archive. Confirm there is only one result and it is the correct entry
When the above steps are successfully completed, the user should be able to perform an EV Search successfully.