Problem
GRT backup of Exchange, Active Directory or SharePoint exits with Status code 41.
Error Message
Error bpbrm (pid=xxxx) from client Client_name: ERR - Unable to NFS mount the required file system.
NBFSD log from the Media Server:
11:07:56.037 [PID.TID] <2> nbfsd_op: completed call 3595 - 0 /NBUFS_A_AA08C9E589FDD6CD_000
11:07:56.037 [PID.TID] <2> nbfs main: mount -o mtype=soft-o timeout=60 -o retry=1 Media_Server:/NBUFS_A_AA08C9E589FDD6CD_000 *
11:07:56.037 [PID.TID] <2> _nbfs_mount_info_check: last access information does not exist, setting it
11:07:56.037 [PID.TID] <16> _nbfs_mount_info_get_name: WNetOpenEnum() failed, error = 1204
11:07:56.037 [PID.TID] <16> _nbfs_mount_info_set: unable to determine last export name
11:07:56.037 [PID.TID] <2> _nbfs_connect: adding connection for Media_Server:/NBUFS_A_AA08C9E589FDD6CD_000
11:07:56.037 [PID.TID] <16> _nbfs_connect: WNetAddConnection2() failed, error = 1204
11:07:57.051 [PID.TID] <16> _nbfs_connect: WNetAddConnection2() failed, error = 1204
11:08:02.121 [PID.TID] <16> _nbfs_connect: WNetAddConnection2() failed, error = 1204 . . .
11:08:57.891 [PID.TID] <16> _nbfs_connect: WNetAddConnection2() failed, error = 1204
11:08:57.891 [PID.TID] <16> _nbfs_connect: aborting connection, timeout period exceeded
If we perform the NFS test described in this article , we can see the 'Exit Status 41 - timeout period exceeded' error when we try to connect to the NFS share on the media server:
C:\Program Files (x86)\Veritas\NetBackup\bin>nbfs mount -server Media_Server -cred 0D982D7C89E491EC2B3E420BD446B2B29885C4E8922F64D5965FE4986309A316B6E83B46655AC2085BF2ED493D5CB1F49ABE83E6A3DAD32B9E4CBD257E2F3120 *
BASEDIR=
MNTPATH=/NBUFS_A_D9CA4EC2395B381B_000
MOUNTPOINT=
aborting connection, timeout period exceeded
EXIT_STATUS=41
------------------
To confirm that it's not a NetBackup error, run the following command from a command prompt on the client:
C:\>mount -o timeout=10 <Media Server>:<MNTPATH> Drive Letter
For example:
C:\>mount -o timeout=10 Media_Server:/NBUFS_A_D9CA4EC2395B381B_000 Z:
Network Error - 1204
Type 'NET HELPMSG 1204' for more information
C:\> NET HELPMSG 1204
"The specified network provider name is invalid"
Cause
This issue is caused due to an unknown corruption in the Client for NFS service on the Exchange, Active Directory or SharePoint server that's being backed up.
Solution
1. Uninstall the Client for NFS feature from the client machine (Add Roles and Features in the Server Manager)
2. Reboot the client machine
3. Install the Client for NFS feature by following the steps mentioned here.