Problem
Veritas eDiscovery v9.1 upgrade installation fails during the Muhimbi (PDF Converter Services) portion with errors.
Error Message
"Invalid Digital Signatures
"Observed in the Muhimbi log - "A file that is required cannot be installed because the cabinet file [long path to cab file] has an invalid digital signature. This may indicate that the cabinet file is corrupt."
Cause
eDP v9.1 includes a Muhimbi upgrade to v8.3.2. Starting with Muhimbi v8.x the PDF Converter Service requires digital signatures for the installation.
- If the eDiscovery server being upgraded has access to the public internet during upgrade the Muhimbi installer will go out to the internet and install the digital certificates during the installation.
- If the eDiscovery server being upgraded does not have access to the public internet during the upgrade the Muhimbi portion of the upgrade installation will FAIL.
Solution
For eDP servers that do not have access to the internet - the certificates should be installed in the Trusted Root Certification Authorities prior to beginning the eDiscovery v9.1 upgrade installer.
For eDP version 9.1 upgrade:
Navigate to this Muhimbi Support site - https://support.muhimbi.com/hc/en-us/articles/228088907-Invalid-digital-signature-during-installation
Find the instructions near the bottom of the article for download and install.
- Download the Muhimbi certificate for version 8.1 and later (eDP uses v8.3.2)
- Download the GlobalSign Root R1 certificate.
- For each downloaded certificate, right-click the file and select Install Certificate.
- Follow the wizard to install all certificates in the Trusted Root Certification Authorities.
Once certificates are installed the eDP upgrade installer may be run.