NetBackup Catalog backup fails with none of the requested files were backed up (2)

Article: 100044085
Last Published: 2022-12-09
Ratings: 0 2
Product(s): NetBackup & Alta Data Protection

Problem

Catalog backup fails with Status Code 2

 

Error Message

Activity Monitor > Detailed Status of the job:

Error bpdbm (pid=37557) error validating NBDB backup in /usr/openv/db/staging.
...
none of the requested files were backed up (2)

BPDBM log file:

/usr/openv/netbackup/logs/bpdbm/root.091718_00001.log

09:33:33.527 [37557] <16> validate_database_with_output: Database validation failed for database NBDB
09:33:33.527 [37557] <16> do_online_nbdb_backup: error validating NBDB backup in /usr/openv/db/staging.
09:33:37.568 [37557] <16> ImageCatalogBackup::executeQuery: exec_asa_database_backup() failed (2)

 

Cause

The NetBackup DataBase (NBDB) validate failed.

 

Solution

Recommend a rebuild of the NBDB, per steps below.

1.  Shut down NetBackup on the master server.

Unix:
/usr/openv/netbackup/bin/bp.kill_all

Windows:
"C:\Program Files\Veritas\NetBackup\bin\bpdown" -f -v

2.  Make a copy of the database folder.

Note: The save folder can be deleted at the successful completion of the next catalog backup.

Unix:
mkdir /usr/openv/db/save
cp -rp /usr/openv/db/data /usr/openv/db/save

  
Windows:
mkdir "C:\Program Files\Veritas\NetBackupDB\save"
copy "C:\Program Files\Veritas\NetBackupDB\data" "C:\Program Files\Veritas\NetBackupDB\save"


3.  Enable debug log folder, or verify that the nbdb folder exists.

Unix:
mkdir /usr/openv/netbackup/logs/nbdb
  
Windows:
mkdir "C:\Program Files\Veritas\NetBackup\logs\nbdb"
   

4.  Start the NetBackup Relational Database.

Unix:
/usr/openv/netbackup/bin/nbdbms_start_stop start
/usr/openv/netbackup/bin/bpps -x
(ensure that NB_dbsrv is active)
/usr/openv/db/bin/nbdb_ping (ensure that NBDB is alive and well)
  
Windows:
"C:\Program Files\Veritas\NetBackup\bin\bpup" -e SQLANYs_VERITAS_NB
"C:\Program Files\Veritas\NetBackup\bin\bpps"
(ensure that dbsrv16 is acitve)
"C:\Program Files\Veritas\NetBackup\bin\nbdb_ping" (ensure that NBDB is alive and well)

5.  Rebuild the database.

Unix:
/usr/openv/db/bin/nbdb_unload -dbn NBDB -rebuild -verbose
  
Windows:
"C:\Program Files\Veritas\NetBackup\bin\nbdb_unload" -dbn NBDB -rebuild -verbose
  

6.  Restart NetBackup.

Unix:
/usr/openv/netbackup/bin/bp.kill_all
/usr/openv/netbackup/bin/bp.start_all

  
Windows:
"C:\Program Files\Veritas\NetBackup\bin\bpdown" -f -v
"C:\Program Files\Veritas\NetBackup\bin\bpup" -f -v

7.  Run the NetBackup catalog backup policy.

 

References

Etrack : 4088071

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