The NetBackup Web Management Console service fails to initialize properly

Article: 100041568
Last Published: 2018-01-12
Ratings: 0 0
Product(s): NetBackup

Problem

On a NetBackup 8.1 Windows Master Server, the NetBackup Web Management Console (nbwmc) service starts and stays running, but it does not start properly.

 

Error Message

nbcertcmd -ping fails with:
C:\Program Files\Veritas\NetBackup\bin>nbcertcmd -ping

nbcertcmd: The -ping operation failed.
EXIT STATUS 26: client/server handshaking failed

The install_path\NetBackup\wmc\webserver\logs\catalina.YYYY-MM-DD.log file shows the following startup error:

29-Dec-2017 14:49:16.343 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["https-pbx-1556"]
29-Dec-2017 14:49:17.297 SEVERE [main] org.apache.catalina.core.StandardService.initInternal Failed to initialize connector [Connector[com.netbackup.tomcat.pbxconnector.Http11PBXProtocol-1556]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[com.netbackup.tomcat.pbxconnector.Http11PBXProtocol-1556]]
     at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:107)
     at org.apache.catalina.core.StandardService.initInternal(StandardService.java:568)
     at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
     at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:871)
     at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
     at org.apache.catalina.startup.Catalina.load(Catalina.java:581)
     at org.apache.catalina.startup.Catalina.load(Catalina.java:604)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:498)
     at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:310)
     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:484)
Caused by: java.lang.UnsatisfiedLinkError: R:\Program Files\Veritas\NetBackup\bin\PBXServerSocket.dll: Can't find dependent libraries
     at java.lang.ClassLoader$NativeLibrary.load(Native Method)
     at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
     at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857)
     at java.lang.Runtime.loadLibrary0(Runtime.java:870)
     at java.lang.System.loadLibrary(System.java:1122)
     at com.ociweb.PBXServerSocket.<clinit>(PBXServerSocket.java:127)
     at com.netbackup.tomcat.pbxconnector.PBXEndpoint.doBind(PBXEndpoint.java:199)
     at com.netbackup.tomcat.baseconnector.BaseEndpoint.bind(BaseEndpoint.java:388)
     at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:810)
     at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:476)
     at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:120)
     at org.apache.catalina.connector.Connector.initInternal(Connector.java:960)
     at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
     ... 12 more

 

Cause

During startup, nbwmc attempts to connect to PBX. In this case, the dll named PBXServerSocket.dll is attempting to connect to vxPBX.dll (also located in install_path\NetBackup\bin), but it is unable to find vxPBX.dll.

Upon startup, the nbwmc service reads a list of variables from a file called install_path\NetBackup\wmc\bin\setenv.bat.
Among the variables which are read is a PATH variable.

In the case above, the PATH variable was entirely absent from setenv.bat.

The setenv.bat file is created during install of NetBackup. It is created upon the execution of install_path\NetBackup\wmc\bin\install\configureEnv.bat.

Simply rerunning configureEnv.bat (with proper switches) ought to rebuild setenv.bat, but in this case, subsequent executions of configureEnv.bat continued to result in a setenv.bat file where PATH was absent.

Further investigation revealed the local OS environment variable for PATH held an unmatched quote mark at the end of a path. When configureEnv.bat attempted to merge the working PATH into setenv.bat, the unmatched quote mark caused the script to redirect the ECHO SET statement to the screen rather than into setenv.bat.

Example:
Image


 

Solution

Because the PATH environment variable on windows is semicolon delimited, quote marks around paths are entirely unnecessary.

To fix this issue, correct the problematic OS environment variable PATH by removing all quote marks (matched or unmatched). Launch a new Administrator CMD window so it adopts the correct PATH environment variable.

Then follow these steps to rebuild setenv.bat:
1. Change directory: cd install_path\NetBackup\wmc\bin\install
2. Execute command: configureEnv.bat -platform %PROCESSOR_ARCHITECTURE% -nbInstallDir install_path
3. Examine the resulting install_path\NetBackup\wmc\bin\setenv.bat for inclusion of the SET PATH variable.

Example:
Image
 

Once populated correctly, the NetBackup Web Management Console service should be able to locate all necessary PBX library files and launch properly.

 

Was this content helpful?