Amazon Cloud Storage device offline after Amazon S3 bucket contents migrated to Amazon Glacier storage.

Article: 100040581
Last Published: 2025-01-02
Ratings: 1 0
Product(s): Backup Exec

Problem

Backup Exec Amazon Cloud Storage device offline after the Amazon S3 bucket contents are migrated or Archived by Amazon S3 bucket lifecycle policy.

 

Error

Application Event Log:

Storage Warning
(Server: ""Media Server"") S3:amazon:amazon.com:backupexec-bucket - Unable to connect to the OpenStorage device.  Ensure that the network is properly configured between the device and the Backup Exec server.

 

Backup Exec ADAMM Log: (\Program Files\Symantec\Backup Exec\Logs\Adamm.log or \Program Files\Veritas\Backup Exec\Logs\Adamm.log)


DeviceIo: beost: Critical: Error while reading data from cloud storage ( V-455-2)
DeviceIo: sts_open_image failed BEOST_SInf BEOST_SInf 2060037
eviceIo: ostutil: FindOstInfo failed to open BEOST_Sinf with error 2060037
DeviceIo: ostutil: S3:amazon:amazon.com FindOstInfo missing BEOST_SInf AND LSU is not empty 'BEOST_00000001'
DeviceIo: beost: Critical: Error while reading data from cloud storage ( V-455-2)
DeviceIo: sts_open_image failed BEOST_SInf-Bak BEOST_SInf 2060037
eviceIo: ostutil: FindOstInfo failed to open BEOST_Sinf-Bak with error 2060037



----------------------------------------------------------------------------------------------------

    Server Name                S3:amazon:amazon.com
    LSU Name                   backupexec-bucket
    User Id                    XXXXXXXXXXXXXXXXXXXX
    Maximum Concurrency        2
    Maximum Image Size         51200 MB
    Block Size                 64 KB
    Discover Status            ERROR = 0xA0009B23 (E_PVL_OST_CONNECT_FAILURE)

----------------------------------------------------------------------------------------------------
 

 


Backup Exec SGMON Debug Log:


PVLSVR: DeviceIo: beost: Critical: Error while reading data from cloud storage ( V-455-2)
PVLSVR: DeviceIo: beost: Debug: amazon:amazon.com: leave open_image
PVLSVR: DeviceIo: sts_open_image failed BEOST_SInf-Bak BEOST_SInf 2060037
PVLSVR: DeviceIo: ostutil: sts_open_image BEOST_SInf-Bak BEOST_SInf 2060037 3.072573 seconds
PVLSVR: DeviceIo: ostutil: FindOstInfo failed to open BEOST_Sinf-Bak with error 2060037

 

 

Cause

Amazon S3 Bucket Folder content for /BEOST_SInf-Bak /BEOST_SInf were migrated or Archived from "Standard" class Amazon S3 storage to Amazon Glacier.

Amazon S3 bucket Lifecyle policy moved the contents to Glacier Storage.

These folder object must be in Simple Storage Service (S3) Standard.
 

Solution

1. Use the AWS console or a 3rd party Amazon S3 browser to view the bucket content. 

2. Confirm if the /BEOST_SInf-Bak  or /BEOST_SInf folder and contents are in Storage class type "Glacier".

3. If these folders and thier content are in Amazon Glacier storage, they must be transitioned from Amazon Glacier to Simple Amazon Storage Service (S3) Standard.

4. Restart the Backup Exec services after transitioning the two folders from Glacier storage to Standard storage.

5. If these folders ( BEOST_Sinf and BEOST_Sinf-Bak ) are not found, contact Backup Exec Technical Support to recreate these files and get the Cloud storage online.

6. Disable or adjust the S3 Bucket Lifecycle policy to not move the objects from standard storage.

Managing the lifecycle of objects
Setting an S3 Lifecycle configuration on a bucket
 


Please note that this article references sites not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.
 

 

 

 

Was this content helpful?