Problem
Items stop being indexed within an Enterprise Vault Archive or Archives. This can result in a backlog of items within the JournalArchive SQL table. To determine how many index volumes have a backlog of indexable items please refer to related article 100037916.
Error Message
The following error message is generated in the Enterprise Vault Event Log:Event ID - 41352
Category - Index Volumes Processor
Description - The processing of the Index Volume has stopped following errors.
Archive name: John Doe
Index Volume ID: 19D210DC645F4BD4DBAAB7D67B50EAD3B1110000vaultsite.Veritas.com_306681
Error Type: NonCritical
Description: Request terminated prematurely. Inner exception: The exception [xml-unset-var-error] was thrown.
V-437-41352
Cause
The error is generated from the Enterprise Vault Indexing Engine.
Workaround
Currently there are two potential workarounds.
OPTION 1
Perform an Index Synchronization. To do this perform the following steps:
- Open the Vault Administration Console and expand the site name.
- Right-click on Indexing and select Manage Indexes.
- Click on Synchronize.
- Follow the wizard and add the relevant Index Volume to be synchronized.
- Choose to Monitor Tasks and confirm that the task is successful or fails.
- If it has been successful, confirm that the correct number of items have been added and the backlog has been processed.
- If the task failed or the expected items have not been processed open the report file generated.
- if the index synchronization report reveals the same error move on to Option 2.
Synchronize index volume started at 12/12/2016 13:59:56
Archive Name: John Doe
Archive Id: 19D210DC645F4BD4DBAAB7D67B50EAD3B1110000vaultsite.Veritas.com
Index Volume Identity: 306681
Index Volume Range: 1-
Root Path Id: 10D1EDC29C7289841B90D9EEEEC4215981810000vaultsite. Veritas.com
Folder: 19D210DC645F4BD4DBAAB7D67B50EAD3B_306681
Root Path: I:\index\index1
Index Server: vaultsvr.Veritas.com
Volume Type: 64-bit
Checking index volume for failed state.
The index volume is not marked as failed.
The synchronize paused as it encountered an error.
The synchronize has resumed its processing.
The synchronize paused as it encountered an error.
The synchronize has resumed its processing.
The synchronize subtask has failed.
Error Code: 57
Description:Request terminated prematurely. The exception [xml-unset-var-error] was thrown.
A Dtrace against the EVIndexVolumesProcessor process provides the following information:
(EVIndexVolumesProcessor) <Agent Thread for 19D210DC645F4BD4DBAAB7D67B50EAD3B1110000vaultsite.Veritas.com_306681 :7776> EV-L {IndexingWCFProxy`1} SOAP FAULT: detail xml = <exception time="344" date="1481501930" id="XML_UNSET_VAR" function="vivisimo_load" fid="51" process="*" name="xml-unset-var-error" stack-trace="//scope/set-var[@name='result']/scope///function[@name='collection-broker-crawler-offline-status']/scope/set-var[@name='response']/function[@name='collection-broker-command']/scope/exception[@id='XML_UNSET_VAR']" xmlns="urn:/velocity/objects">Cannot get value of <string name="name">result</string>: declared but not set to anything in scope <xmlnode name="path" xpath="//scope/set-var[@name='result']/scope///function[@name='collection-broker-crawler-offline-status']/scope/set-var[@name='response']/function[@name='collection-broker-command']/scope"></xmlnode> </exception>
OPTION 2
Rebuild the Index Volume.
To perform an index rebuild perform the same steps as workaround Option 1 but this time choose Rebuild.
****NOTE**** - An index rebuild could take a significant amount of time to complete depending on the amount of items in the index volume that have previously been successfully indexed.
Solution
This issue has been addressed in the following release available from Downloads:Enterprise Vault 12.2