Scheduled SQL Server backups fail with Status Code 2, along with bphdb reporting "Unable to get user profile information, status=1722"

Article: 100032299
Last Published: 2022-10-27
Ratings: 1 0
Product(s): NetBackup & Alta Data Protection

Problem

Using a SQL backup policy with SIP or stand-alone the backup job will report, "none of the requested files were backed up (2)".  The user instructed to perform the backup hasn't logged in.

Error Message

The following can be observed in the debug log files:

bphdb shows:
17:45:10.039 [8960.10340] <2> debuglog: <2> ProcessMgr::ncfsvc: Activating process for command "C:\Program Files\Veritas\NetBackup\bin\dbbackex.exe" -np -s netbackup -ipf "input.8960.0.0407116.174509" -pjobid 30174 (../ProcessMgr.cpp:655)
17:45:12.367 [8960.10340] <2> debuglog: <2> ImpersonatePlatform::doImpersonation: Unable to get user profile information, status=1722 (../ImpersonateWin.cpp:201)
 
dbclient:
17:45:12.664 [3868.4780] <16> DB_CryptAcquireContext: ERR - Error in CryptAcquireContext : 2.
17:45:12.664 [3868.4780] <1> DB_CryptAcquireContext: CONTINUATION: - The system cannot find the file specified.
 

Cause

When reviewing the CryptAcquireContext function we see the error code of "ERROR_FILE_NOT_FOUND
2L" is reported when there is no user profile to be loaded:
https://learn.microsoft.com/en-us/windows/win32/api/wincrypt/nf-wincrypt-cryptacquirecontexta 

The observed error, "Unable to get user profile information, status=1722" found in the bphdb shows that there is no user profile when trying to change to the account used for backups.

Solution

Sign in once as the user that NetBackup is using for SQL Server backups. The user profile will be created for the user specified after which NetBackup backups will proceed.

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