Status code 23, socket read failed, during client backups or restores, or when loading client properties.

Article: 100030186
Last Published: 2011-11-25
Ratings: 0 1
Product(s): NetBackup & Alta Data Protection

Problem

General Error: Status code 23, socket read failed, during client backups or restores, or when loading client properties.

 

Error Message

Status code 23, socket read failed

 

Cause

The keyfile.dat file in the <Install_Path>\NetBackup\bin\ directory resulted in bpcd issuing the prompt and waiting for a passphrase, and remaining as a running process.

 

Troubleshooting:

  • Verify that bpcd is listening on the client, and attempt to connect to the bpcd port (13782) on the client in question.   It is possible that bpcd will be listening on the client, and that telnet will succeed from both the master/media server to the client, as well as from the client to itself when this problem is seen.

Example:  telnet <client name> 13782

  • If the telnet to the bpcd port is successful, it will typically log results in the bpcd debug log.   However, if this issue is seen, nothing will be logged, despite the successful connections being made to the port.  

 

  • Inspect the Task Manager.  If it shows a large number of bpcd processes running, and additional bpcd are accumulating for each subsequent telnet to the bpcd port, this is further indication that this issue is the cause of the failures.

 

  • Finally see if there is an issue with the bpcd binary.  This can be done by executing the bpcd from the command prompt while in the <install_path>\NetBackup\bin directory:

<Install_path>\NetBackup\bin\bpcd

  • If the result is:  "Please enter keyfile passphrase"

Then check the <install_path>\NetBackup\bin  for the existence of the keyfile.dat file.

 

Solution

The keyfile.dat is associated with the NetBackup Encryption agent.  By default the  keyfile.dat file should exist in the  <install_path>NetBackup\var directory for all supported NetBackup versions.  
 
If needed, the  keyfile.dat file can be moved out of the <Install_Path>\NetBackup\bin directory, after verification that the file exists in the appropriate directory ( NetBackup\var).  At that time, the the keyfile.dat file can be moved out of the  <Install_Path>\NetBackup\bin directory.  After moving the file, restores of older data that was encrypted should be tested along with backups.  Only after testing is completed and is successful, can the  keyfile.dat be deleted.
 
If the file is not located in the correct location  and problems occur with restores and backups that require encryption, Veritas NetBackup Support should be contacted for assistance.




 
 

 

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