Event 41293 Indexing Service fails to start: Configuration Error "The content type text/html; charset=utf-8 of the response message does not match the content type of the binding"
Problem
Enterprise Vault (EV) Indexing service fails to start. Event 41293 logged stating Configuration Error.
Error Message
Dtrace Information:
To validate if this is the issue a Dtrace is needed, please perform the following steps on the EV server that has generated Event ID 41293 while re-creating the issue.
- For more information about Enterprise Vault’s Dtrace Utility please see 100038975.
- Dtrace the process EVIndexAdminService for no less than 5 minutes while re-creating the issue.
- Open the log file created and search for either of the following the string:
{IVMETADATALOCATIONUPDATER.EN_US} Current indexing metadata schema version [1.2] requires mandatory upgrade as major version number is lower than base version [2.0]
Event ID: 41395 Enterprise Vault will now create the indexing metadata. The Indexing service will be unavailable until the metadata has been created. The creation will begin immediately and may take some time to complete.
V-437-41395Event ID: 41293 Configuration Error
{SERVICEBASEEX.EN_US} The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly.
V-437-41293
The remote server returned an error: (500) Internal Server Error.
Cause
Affected scenario: The upgrade of Enterprise Vault (EV) server was aborted. The version mismatch between different files of EV and Indexing component could lead to this problem. The EVInstall log shows following text OnAbort Ended when upgrade has been aborted. The various files of Indexing will show version mismatch, such as in this scenario, the EVIndexingAdminService.exe was showing older version of EV when all other indexing files were at upgraded version of EV.
The occurrence of this issue is rare. Reset of Indexing engine generates error Cannot Downgrade.
Solution
This issue can be resolved by manually resetting the indexing engine. (By copying the EVIndexing folder with contents from similar version of EV server)
1. Copy the EVIndexing folder <Install_path>\Enterprisevault\EVIndexing from same EV server version.
2. Rename the Indexmetadata folder located <Install_path>\Enterprisevault\EVIndexing\data\indexmetadata.
3. Start the EV Indexing Service.
4. Upon starting the Indexing service, initialization process will create the indexing metadata which will show via Event 41395.
5. Once the Indexing Metadata has been created, Indexing service start event will be logged.