Problem
Indexing Service does not start or will randomly fail after few hours logging the below events :
Error Message
Log Name: Symantec Enterprise Vault
Source: Enterprise Vault
Date: 12/4/2012 2:48:03 AM
Event ID: 41369
Task Category: Index Admin Service
Level: Warning
Keywords: Classic
User: N/A
Computer: UK.arak.cb.net
Description:
An error occurred while synchronizing Indexing Engine metadata for Index volume XXXX [Archive EntryId: AAAA.zone1.cccc.net].
Error Details:
Unable to extract
V-437-41369
Log Name: Symantec Enterprise Vault
Source: Enterprise Vault
Date: 12/4/2012 3:48:07 AM
Event ID: 41335
Task Category: Index Admin Service
Level: Error
Keywords: Classic
User: N/A
Computer: aaaa.cc.net
Description:
An error occurred while trying to start indexing engine.
Further error details include: 'The request channel timed out while waiting for a reply after 01:00:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.'.
V-437-41335
V-437-41312
V-437-41374
Dtrace will capture the following :
4212 11:02:31.559 [10244] (EVIndexAdminService) <22784> EV~E |Event ID: 41335 An error occurred while trying to start indexing engine.|Further error details include: 'The request channel timed out while waiting for a reply after 01:00:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.'.
4213 11:02:31.559 [10244] (EVIndexAdminService) <22784> EV-H {INDEXADMINSERVICE.EN_US} The Indexing Service could not complete all the required startup routine: Starting Index Engine failed.. Service will be stopped.
4214 11:02:31.559 [10244] (EVIndexAdminService) <22784> EV~E |Event ID: 41312 The Indexing Service could not complete all the required startup routines: Starting Index Engine failed. Service will be stopped.
4215 11:02:31.559 [10244] (EVIndexAdminService) <22784> EV-H {SERVICEBASEEX.EN_US} Exception of type 'KVS.EnterpriseVault.Common.ServiceBaseExException' was thrown.
And :
1427 10:02:26.603 [10244] (EVIndexAdminService) <IVMetadataSync_LogThread:23284> EV~I |Event ID: 41374 Indexing Service is synchronizing index volume metadata between the indexing engine repository and the Directory database.
1428 10:02:26.837 [10244] (EVIndexAdminService) <IVMetadataSync_SyncThread_25:8328> EV-L {IndexingWCFProxy`1} [3599971ms] Called SearchCollectionStatus
1429 10:02:26.837 [10244] (EVIndexAdminService) <IVMetadataSync_SyncThread_25:8328> EV-H {VELOCITYPROXY.EN_US} Cannot get collection status for [XXXXX]. The request channel timed out while waiting for a reply after 01:00:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.
1430 10:02:26.837 [10244] (EVIndexAdminService) <IVMetadataSync_SyncThread_25:8328> EV-H {VELOCITYPROXY.EN_US} Collection [XXXXX]. Indexing engine exception.
Cause
Corruption with EVIndexing folder - repository.xml
Solution
- Examine the contents of the repository.xml for potential corruption.
Note: HOWTO56259 provides more information on the purpose and functionality of the repository.xml
- Reset the corrupt 64-bit Indexing Engine
Note: Review HOWTO59060 for more information about this task.
Applies To
Enterprise Vault 10.0.1 (MCS Cluster)