Backup Exec service pack or hotfix installation fails with Error 1328. Error applying patch to file.

Article: 100028054
Last Published: 2017-12-18
Ratings: 1 0
Product(s): Backup Exec

Problem

When installing Backup Exec service pack or hotfix the following error is reported.

Error 1328.Error applying patch to file. It has probably been updated by other means, and can no longer be modified by this patch. For more information contact your patch vendor.

Error Message

BKUPINST log shows the following errors

---------------------------------------------------------------
ERROR: Error 1328.Error applying patch to file C:\Config.Msi\PT1088.tmp. It has probably been updated by other means, and can no longer be modified by this patch. For more information contact your patch vendor.
---------------------------------------------------------------

MSI debug shows the following errors

---------------------------------------------------------------
DEBUG: Error 2851:  The data for the icon InstallManager_DLL is not valid
Internal Error 2851. InstallManager_DLL
DEBUG: Error 2835:  The control ErrorIcon was not found on dialog SetupError
Internal Error 2835. ErrorIcon, SetupError
---------------------------------------------------------------
 

Cause

Installation files cached on the server are corrupt

 

Solution

1.     Go to Start->Run and type 'control.exe folders' (without quotes). This command will open the folder options window

2.     Click on 'view' and uncheck the 'Hide protected operating system files (Recommended)' option under 'Hidden files and folders'

3.     Click 'YES' to the warning, click on 'Apply' and then click on 'OK'

4.     Navigate to C:\Windows\Installer\$PatchCache$\Managed

5.     Perform a search in this directory for the version of Backup Exec installed. 

  • For Backup Exec 2012, search for : 14.0.1798
  • For Backup Exec 2014, search for : 14.1.1786
  • For Backup Exec 16, search for : 16.0.1142
  • For Backup Exec 20.x, search for : 20.0.1188

6.     Rename or delete the resulting folder

7.     Re-run the installer as an administrator and it should complete successfully

 

Applies To

Backup Exec 2012; Backup Exec 2014; Backup Exec 16; Backup Exec 20.x

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