Problem
Manual archive and restoring fails with popup error “Could not process the selected items, reason: an internal error occurred on the web server, CreateObject AA0:424”
Incorrect permission on EV installation folder cause failure on retrieval/ restore and archiving on new emails.
Error Message
Retrieval on archived emails fails with popup “An internal error on web server, Create object:424”
Manual archive / Restore fails with popup “Could not process the selected items, reason an internal error occurred on the web server “CreateObject AA0:424”
Client log:
26/05/2011 08:41:27.703[2812]: CHTTPRequest::CheckStatus
26/05/2011 08:41:27.704[2812]: HTTP request error: 370 (500)
IIS log show clienttest.gif pass with status code 200, remaining other request such as download.asp, clientaction.asp fails with 500 error code
/EnterpriseVault/clienttest.gif - 443 domain\username 172.18.4.164 EnterpriseVaultOutlookExt-V9.0.1.1073 200 0 0
/EnterpriseVault/download.asp VaultID=192A77AD99020634C81B275A9462766A61110000evkbr01&SaveSetID=201104193229280~201011011249500000~ Z~A1072387B34519A43F2E9E53D2EA40D1&FormatType=Unicode&Client=EV9.0.1.1073-Outlook12&Format=MUD&AttachmentID=0 443 SWD\shibuvg 172.18.4.164 EnterpriseVaultOutlookExt-V9.0.1.1073 500 0 0
EnterpriseVault/clientaction.asp act=4&fdrenc=_&dn=/o%3dSuwaidi/ou%3dExchange%20Administrative%20Group%20(FYDIBOHF23SPDLT)/cn%3dRecipients/ cn%3dshibuvg&svr=APKBREXC01&sid=163C47CB5FC085A40A70DBE38C9BF59061d10000evkbr01&tsp=2011-05-26T08:52:57&pdl=AAAAAAAAAPMAECKIGABNPJEJLBOMFMEAEDNGCOMFABAAEHJNDKKPMEKGPNEALLMFBBAHLDDPPNBIAAAAAAOCLKGPAAAA 443 SWD\shibuvg 172.18.4.164 EnterpriseVaultOutlookExt-V9.0.1.1073 500 0 0
DTRACE log fail with the following error:
44 08:03:44.767 [5020] (w3wp) <548> EV:H Calling GenAuthString45 08:03:44.782 [5020] (w3wp) <548> EV:H ClientAuthHelperImpl::GenAuthString Unable to register by impersonated user. hr=Error loading type library/DLL. [0x80029c4a]46 08:03:44.782 [5020] (w3wp) <548> EV:H CClientAuthenticate::GenAuthString exception raised!
Cause
Due to incorrect permission on EV installation folder or DCOM issue, user may encounter issue while manual archive /restore or retrieval of archived emails.
Solution
The following steps will help to troubleshoot the issue.
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
1. Reregister AutoStorageOnlineOpns.dll
C:\Program Files\Enterprise Vault>regsvr32 AutoStorageOnlineopns.dll
2. Verify the loopback registry key exists.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
Dword DisableLoopbackCheck
value = 1
3. Check the permissions on EV installation directory.
Give read & execute, list, read permission to Authenticated users.
4. Restart IIS.
If the issue still persists, recycle the AppPool for Enterprise Vault via IIS.