Remote Agent service does not start automatically after a server reboot.

Article: 100024806
Last Published: 2025-01-06
Ratings: 1 2
Product(s): Backup Exec

Problem

Backup Exec Remote Agent service (BEREMOTE.exe) does not start automatically after a server reboot.

Error Message

 The service did not respond to the start or control request in a timely fashion

Cause

This can occur if the server has an excessive amount of startup activity that delays the service from starting within the Windows Service timeout period.

Solution

 Add a Windows Scheduled Task to start the file BESTART.BAT after a server reboot.

1. Create BESTART.TXT and place it in \Program FilesVeritas\Backup Exec\RAWS

2. Edit the newly created BESTART.TXT and add the following:

@echo off
echo.
echo.Starting the Backup Exec Remote Agent service...
echo.
TIMEOUT.EXE /T 300
net start "Backup Exec Remote Agent for Windows" > nul
exit

3. Save BESTART.TXT and rename it to BESTART.BAT

Note:  "TIMEOUT.EXE /T 300" will delay the start of the Backup Exec Remote Agent service for 5 minutes (300seconds = 5 minutes). Should this not be enough time before starting the service, the delay can be set higher.
 
4. Create a Windows Scheduled Task from " Start | Programs | Accessories | System Tools | Task Scheduler" - Go through the Scheduled Task Wizard directing it to the newly created BESTART.BAT file in the location \Program FilesVeritas\Backup Exec\bestart.bat and Set it to run 'When my computer starts'
 

 

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