V-76-58645-585: Failed to reserve a majority of disks in cluster dynamic disk group

Article: 100023267
Last Published: 2022-01-27
Ratings: 2 0
Product(s): InfoScale & Storage Foundation

Problem

When attempting to import a cluster diskgroup, the operation would fail

 

Error Message

V-76-58645-585: Failed to reserve a majority of disks in cluster dynamic disk group

Cause

This error generally happens in the following scenarios:
1. When the cluster diskgroup has less than 50% healthy disks that are able to be imported.
2. When a diskgroup with private diskgroup protection has less than 50% healthy disks that are able to be imported.
3. When no disks in the diskgroup can be SCSI reserved or at least 50% or more cannot be SCSI reserved.
 

Solution

There are several ways to resolve and workaround the reserve issue:

Solution 1
================================
Attempt to manually import the Cluster Disk Group using command  
  • vxdg -g DISKGROUP -f import
This will force import a cluster diskgroup that has 50% or less available disks. But if all of the disks are unavailable or cannot be SCSI reserved, this may fail to import the cluster Disk Group with the following message:
Failed to complete the operation...V-76-58645-585: Failed to reserve a majority of disks in cluster dynamic disk group.

Should the above error occur, then continue to with the solutions below


Solution 2
================================
Use the command syntax below
 
vxclus.exe ENABLE -g DISKGROUP -p

However if the Cluster Diskgroup fails to import and shows any of the following messages then continue with other solutions below

V-77-57616-50002: Warning: Make sure that a majority of the disk group disks are NOT online on any other cluster node before (and after) using this utility. If a majority of the disks are online on another node,
data corruption can occur.  Please consult documentation or technical support for any questions if you are unsure of the usage of the operation. Are you sure you want to proceed with the operation(Y/N)?y

V-77-57616-4037: ****** Enable Force Import for Disk Group DISKGROUP-1



Solution 3
================================
It is possible that a persistent SCSI 3 reservations are preventing the disk from importing and deporting.

Obtain a utility called SCSIcmd.zip from  SCSICMD Tool

This tool can be used to clear SCSI reservations. An example of the syntax would be similar to the following
  • scsicmd -dAll0,1 -sscsi3_release

-dAll0,1 = release reservations on ALL disks except 0 and 1 (because these are local disks, which may be only 0 in your server)

This may be a interim solution as the problem may surface again. Work with the Hardware Vendor to establish correct working practices for SCSI-3 reservation methodology


Solution 4
================================
Obtain the latest Host Bus Adapter (HBA) card drivers and upgrade all the drivers on all the cluster nodes ensuring that all drivers are the same revision. 


Solution 5
================================
If this is a MSCS cluster, and the cluster was destroyed while one nodes was down, It will be necessary to run the destroy cluster wizard from that node. This will stop the cluster from placing a SCSI reservation on the disk once imported.

 

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