Problem
Review or export of items in Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA) fails with the error as listed below.
Error Message
Cannot retrieve item. Report this error to your system administrator. Failed to acquire file lock on C:\Documents and Settings\vaultsvc\Local Settings\Temp\EcmAPI\Ox+DvpEcHTXX8+SR2bvCPUpUz13= in 30 seconds
Source: Accelerator Service Processor
Category: None
Event Type: Error
Event ID: 375
Description:
APP AS - Customer ID: 1 - An Error has occured when retrieving item
SaveSetID: 200908180000000~200401011240390000~Z~B08EDE48AB001D8F8AD09A530838A641
VaultID: 123A4BC567D8EF9012A3B4567C8901D2E1110000EVSITE
Format: XML
sAttachmentID: 0.
System.Exception: Failed to acquire file lock on C:\Documents and Settings\vaultsvc\Local
Settings\Temp\EcmAPI\Ox+DvpEcHTXX8+SR2bvCPUpUz13= in 30 seconds at KVS.Accelerator.Common.FileLock..ctor(String fileName, TimeSpan timeout)
at KVS.Accelerator.Common.FileLock..ctor(String fileName) at KVS.Common.VaultItem.Item.GetEcmArchivedItem(String sSaveSetID,String sVaultID, String sAttachmentID, String sFormat)
at KVS.Common.VaultItem.Item.GetItemFromECM(String itemID, String sSaveSetID, String sAttachmentID, String sFormat, String sVaultID,MessageType msgType)
A dtrace of the AcceleratorService on the DA server when the issue occurs would contain lines similar to:- EV-H {ITEM.EN_US} Exception: Failed to acquire file lock on C:\Documents and Settings\vaultsvc\Local Settings\Temp\EcmAPI\Ox+DvpEcHTXX8+SR2bvCPUpUz13= in 30 seconds
Info:{C6.EN_US} ECM cache access error Diag: Type:System.Exception ST: at KVS.Accelerator.Common.FileLock..ctor(String fileName, TimeSpan timeout)| at KVS.Accelerator.Common.FileLock..ctor(String fileName)| at
KVS.Common.VaultItem.Item.GetEcmArchivedItem(String sSaveSetID, String sVaultID, String sAttachmentID, String sFormat)
- EV-H {-} Exception: Error VaultItem_ItemGet2 Info:{ACCELERATOREVENT.EN_US} {C6.EN_US} An Error has occured when retrieving Item|SaveSetID:
200908180000000~200401011240390000~Z~B08EDE48AB001D8F8AD09A530838A641|VaultID: 123A4BC567D8EF9012A3B4567C8901D2E1110000EVSITE|Format: XML|sAttachmentID: 0.|System.Exception: Failed to acquire
file lock on C:\Documents and Settings\vaultsvc\Local Settings\Temp\EcmAPI\Ox+DvpEcHTXX8+SR2bvCPUpUz13= in 30 seconds| at KVS.Accelerator.Common.FileLock..ctor(String fileName, TimeSpan timeout)| at
KVS.Accelerator.Common.FileLock..ctor(String fileName)| at KVS.Common.VaultItem.Item.GetEcmArchivedItem(String sSaveSetID, String sVaultID, String sAttachmentID, String sFormat)| at
KVS.Common.VaultItem.Item.GetItemFromECM(String itemID, String sSaveSetID, String sAttachmentID, String sFormat, String sVaultID, MessageType msgType) Diag: Type:System.Exception ST:
- EV-H {RBO_ITEMCONTENT.EN_US} Exception: Failed to acquire file lock on C:\Documents and Settings\vaultsvc\Local Settings\Temp\EcmAPI\Ox+DvpEcHTXX8+SR2bvCPUpUz13= in 30
seconds Info:{C6.EN_US} RBO method failed Diag: Type:System.Exception ST: at KVS.Common.VaultItem.Item.GetItemFromECM(String itemID, String sSaveSetID, String sAttachmentID, String sFormat, String sVaultID, MessageType msgType) at KVS.Common.VaultItem.Item.GetItem(String itemID, String sSaveSetID, String sAttachmentID, String sFormat, String sVaultID, MessageType msgType)| at KVS.Accelerator.RBO.RBO_ItemContent.GetContent(Int32 proxyID, EFormat format, ItemIDType idType, Int64 itemID, Int32 attachmentID, Int64 offset, Int32 count)
Cause
Enterprise Vault (EV) Compliance Accelerator (CA) and Discovery Accelerator (DA) use the ECM-API to access items for review in order to display BCC recipient information and to improve retrieval performance in the review pane. The ECM-API is also used to retrieve items from storage in order to export or Produce them for external review. If the CA or DA server is not set up properly, reviewing or exporting / producing messages can randomly throw the error above and appear to freeze the review or export / production process. The Enterprise Vault Event Log on the CA or DA server will have the errors noted in the Error section.
By default, the CA and DA review process uses the 'C:\Windows\Temp' folder to retrieve the item to be reviewed and convert it into HTML rendering prior to moving it into the Vault Service Account's 'Temp\EcmAPI' folder. Both folders must be properly configured for the review process to work properly.
Solution
folder or the Vault Service Account's TEMP folder (default location is
C:\Documents and Settings\vaultsvc\Local Settings\Temp
, where vaultsvc represents the user ID of the Vault Service Account)
folder
). Be sure the new location is on a drive that has sufficient free space to accommodate the expected size of exports (i.e., 40 GB for small to medium sized exports, 80 GB or greater for large exports).
in the
Reviewing settings as follows:
role assignment)
) into the value column of this option