Desktop Laptop Option (DLO) Alert: "The desktop agent was unable to create the recovery key file". DLO Client will not open or run backups.
Problem
Desktop Laptop Option (DLO) Alert: "The desktop agent was unable to create the recovery key file \\\\\.dlo\recovery2.7fffffff. The desktop agent will automatically retry". DLO Client will not open or run backups.
Error Message
Check the DLOClient.log file located in the following folder: "X:\Documents and Settings\<USERNAME>\Local Settings\Application Data\Symantec\DLO\.Settings" and look for messages similar to this:
10/19/09 09:46:30 dloclientu.exe 5952: > errorreport.cpp( 294 ) FAILED ASSERTION: shadow\client\clientlib\spamfilter.cpp( line: 111 ): SUCCEEDED ( res )
10/19/09 09:46:30 dloclientu.exe 5952: > errorreport.cpp( 294 ) FAILED ASSERTION: shadow\client\ClientUI\client.cpp( line: 319 ): SUCCEEDED ( res )
Cause
- This may happen to select users, or may happen to all users. Check the DLO Storage location of the affected users.
- Review the permissions on the Storage Location folders. Permissions on the user specific sub-folders might be inheriting permissions from the parent folder that has inadequate permissions.
Solution
Solution 1: Check the NTFS security and the Share permissions on the root NUDF, as well as the sub-folder defined for the user having the problem. It should be configured as follows:
Share Permissions on the root NTFS folder defined as the NUDF
Administrator: Full Control
Everyone: Full Control
Everyone: Read and Execute, Read and List Folder Contents
UserID: Full Control
Solution 2: Create a new Storage Location within the DLO Console and move the users to this new Storage Location. Restart the Desktop Agent and it should connect properly.