Windows System State backups fail with error message - 0xe000fedf - A failure occurred reading an object

Article: 100020186
Last Published: 2022-08-03
Ratings: 0 0
Product(s): Backup Exec

Problem

Windows System State backups fail with error message - 0xe000fedf - A failure occurred reading an object

Error Message

Final error: 0xe000fedf - A failure occurred reading an object

The above error appears in the job log after a failed attempt to backup a Windows System State
 
Also included in the job log can be
 
VSS Snapshot warning. File c:\windows\inf\oem12.inf is not present on the snapshot
 
V-79-57344-65247 - A failure occurred reading an object
 

Cause

The problem occurs if registry entries point to a file that is no longer on the system, normally after a program has been uninstalled.  This exception has been reported on an assortment of files and on most supported versions of the Windows operating system.

Solution

 
Issues with multiple files may cause the above error.  As the job log does not include all problem files, debugging for the Remote Agent service should be enabled to confirm the specific files.  
 
Note: Enable Sg-Mon debugging for job engine and remote agent .  if the affected machine is a remote server, debug the remote server using beutility on the media server as instructed by using the branch "all remote agent computers".
 
The debug log files will be located in \program files\veritas\backup exec\logs\[servername]-beremote[xx].log.  Review the most recently modified file in this folder for examples of messages similar to the following:
 
[10300] 02/06/09 14:20:02 Status 0x00000002 returned calling FindFirstFile for \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy75\windows\inf\oem12.inf in brUtil::GenerateFileList
 
[10300] 02/06/09 14:21:50 brUtil::OpenActiveObject Error: 0xE0008485 Could not open the object msidcrl30.dll C:\Windows\winsxs\amd64_microsoft-windows-identitycrl_31bf3856ad364e35_6.0.6001.18000_none_adac6f6ef6bbe059\msidcrl30.dll
  
In the above example, oem12.inf was actually missing - replacing the file was necessary. Also the msidcrl30.dll was corrupt - deleting the file was necessary.  Msidcrl30.dll was confirmed as corrupt by using the Microsoft backup tool that can be installed with Windows 2008.  This tool is not installed by default.  Once installed, a system state only backup can be performed via the command line:
 
wbadmin start systemstatebackup -backuptarget:e:
 
When the job has finished, any logs by default are saved in c:\windows\logs\windowserverbackup\*.log.  Review the error log file to confirm which files cannot be backed up due to corruption.  In this example, manually attempting to copy the file generated an access denied error, even when ownership permissions were assumed and full control given.  If the file had been locked open by a running process then VSS should have been able to snapshot it therefore the file was corrupt.
 
Workaround:
 
Once any affected files have been identified, arrange to delete and/or replace any affected files.
 

 

 

 

Was this content helpful?