Event 375 - 0xC0041A69 - Compliance Accelerator or Discovery Accelerator export hung in a 'retrying' status
Problem
Enterprise Vault Compliance & Discovery Accelerator export hung in a 'retrying' status until manually stopped. Produces 0xC0041A69 error for certain items.
Error Message
When using Compliance or Discovery Accelerator to export items to pst, the export may sit in a 'Retrying' loop. At close inspection of the export, an error will be present only on certain items. In addition, the following error event will be logged on the Discovery or Compliance server:
Type: Error
Event: 375
Source: Accelerator Service Processor
Computer: SERVER
Description:
APP AT - Customer ID: 2 - An Error has occured when retrieving Item
SaveSetID: 509000000000000~200804230036550000~0~64B9CDE2731749EA99B64E9464DA547
VaultID: 1B4F869D3A71A944F9EFEC505D87C7C7D1110000SITE.domain.com
Format: MSG:U
sAttachmentID: 0.
System.Runtime.InteropServices.COMException (0xC0041A69): Exception from HRESULT: 0xC0041A69
At the same time, on the Enterprise Vault server hosting the vault/archive which contains the item, the follow event will be seen:
Type: Error
Event: 6761
Source: Enterprise Vault
Computer: SERVER
Description:
NetworkPacket.checkControl(2)<HPPReadBlobTransaction.readBytes(HPPImportData&)<HPPReadBlobTransaction.run()<ClusterCloud::readBlob(FPBasicGenericStream*,8DF8H9KT2STQ2e5OLSGRSGSOUKGG4134B8S2VV01E6QOPDNQ1KNHN,,0,-1,-1,0)<FPClip::Open(pool, 8DF8H9KT2STQ2e5OLSGRSGSOUKGG4134B8S2VV01E6QOPDNQ1KNHN, 1)<FPClip_Open(-,8DF8H9KT2STQ2e5OLSGRSGSOUKGG4134B8S2VV01E6QOPDNQ1KNHN,1)
FP_CLIP_NOT_FOUND_ERR
-10021Clip CDF is not found in the pool (transid='SACEV/5547170/READ_CLIP') 172.16.12.23:3218,172.16.45.67:3218?F:\centera\ev.pea
Cause
Typically this problem occurs when the EMC clip no longer exists either due to deletion of the contained saveset by end user or storage expiry has removed the item. Expected behavior is that Enterprise Vault will update the Vault Store database and remove the reference to the item; afterwards the index is also updated preventing subsequent searches from discovering it. However, in some scenarios, it may be possible that the database and index update have not occurred therefore making it possible to capture the item in a search. As a result, an export of those captured items would fail due to the clip having been deleted.
Solution
- Use the browser search (aka: Search.asp) to try and retrieve the item. This will fail as well.
- Check the EMC storage device for the clip id referenced in event 6761 (see above) to see if the clip exists.
- If clip exists, can it be opened?
- If clip exists and it can be opened, does the saveset exist? (Use saveset id referenced in event 375)
Resolution:
To resolve this conflict, Sql will need to match up to what is actually in the vault store. Please contact Veritas Support for further assistance.