When connecting to host properties/master server, the following error are received: "unable to connect to EMM server (77)" and "EMM interface initialization failed, status = 334"

Article: 100018127
Last Published: 2011-05-24
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

- Unable to connect to EMM server (77)
- EMM interface initialization failed, status = 334
- Netbackup Event Manager service won't start
- Lots of nbproxy processes are running

 

Error Message

Netbackup Event Manager service won't start

nbevtmgr log:
-------------
5/19/2011 22:07:35.911 [Application] NB 51216 nbevtmgr 231 PID:4056 TID:9188 File ID:231 [No context] [Error] V-231-190 The NBNosSvc service experienced an error while shutting down
 

The NetBackup Policy Execution Manager service terminated unexpectedly.

nbpem log:
----------
5/19/2011 22:07:38.657 [Diagnostic] NB 51216 nbpem 116 PID:8836 TID:3412 File ID:116 [No context] 1 V-116-285 [NBProxy::doConnect] starting nbproxy E:\Program Files\Veritas\NetBackup\var\nbproxy_pem.ior
5/19/2011 22:07:38.657 [Debug] NB 51216 nbpem 116 PID:8836 TID:3412 File ID:116 [No context] 2 [NBPClient::KillNBP] Found an old proxy with ior file: E:\Program Files\Veritas\NetBackup\var\nbproxy_pem.ior shutting it down

 

Cause

HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG\
"CLIENT_PORT_WINDOW" has changed to 1024 1024 from 0 0

 

Solution


Administrators may see the following error occur when attempting to connect to the host properties on the master server "unable to connect to EMM server (77)" and "EMM interface initialization failed, status = 334"

These errors may occur if the client port window is improperly set.  An example of an improper setting would be the following:
CLIENT_PORT_WINDOW = 1024 1024

The client port window may be inadvertently set to the above range by unselecting the "use OS selected no-reserved ports"  while in the Master server  --> "Host Properties", port ranges area of the GUI:
 


   

 

Administrators can correct this issue by editing the following registry setting:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG
CLIENT_PORT_WINDOW= 1024 1024 (This is wrong)

 

The modified line setting should contain a =0 0 or another desired port range.  Example using 0 0 is as follows:
HKEY_LOCAL_MACHINE\SOFTWARE\NETBACKUP\CURRENT VERSION\CONFIG
CLIENT_PORT_WINDOW=0 0

 

 

Applies To

nbdb_ping returns : Database [NBDB] is alive and well on server [NB_master1]

 

Was this content helpful?