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Article: 100017421
Last Published: 2019-06-18
Ratings: 0 0
Product(s): Enterprise Vault
Problem
Event ID 3231: Could not get a MAPI session from the session pool
Error Message
Event error 0x81002746 :Could not get a MAPI session from the session pool
Cause
This error can occur while starting the Archiving or Journaling service . When the Archiving or Journaling service starts, it attempts to connect to the Archiving or Journal mailbox it is configured to process. An error is logged if it was unable to log in to the mailbox successfully.
This error is so critical that the Archiving or Journal service shuts down automatically. Even the synchronization of mailbox properties can result in such an error.
This issue is most likely due to an underlying Exchange connectivity issue.
- Exchange server may be down.
- Messaging Application Programming Interface (MAPI) connectivity error with Exchange.
- Exchange is unable to resolve the system mailbox.
- System mailbox may be hidden in the Global Address List (GAL).
Solution
Ensure that the Exchange server services are up and running and that the system
mailbox
is not hidden in the GAL. Once those points are successfully verified, carry out general Exchange MAPI
troubleshooting
steps as given in the Related Documents section in article
000028303 - Troubleshooting Exchange connectivity issues with Enterprise Vault (EV).
If the issue is unresolved even after following the MAPI troubleshooting guide, follow these steps to modify each of the following tables within SQL.
If the issue is unresolved even after following the MAPI troubleshooting guide, follow these steps to modify each of the following tables within SQL.
- Stop all Enterprise Vault services
- Open SQL Enterprise Manager or SQL Server Management Studio.
- Click on the New Query button in the toolbar.
- In the New Query window, type and execute the following SQL query:
USE EnterpriseVaultDirectory;
SELECT SystemMailbox FROM ExchangeConnectionPoints;
- Verify the value on each SystemMailbox column in each output and confirm there is no space after SMTP as shown in this example:
Incorrect:
smtp: user@domain.com
Correct:
smtp:user@domain.com
smtp:user@domain.com is the email account will be the account that is listed in the SystemMailbox column.
If the SystemMailbox column has a space, continue with the next step.
- Note the SystemMailbox column for each table and run the following SQL query command:
USE EnterpriseVaultDirectory;
UPDATE ExchangeConnectionPoints SET SystemMailbox = 'Corrected_SMTP_Email_Address'
WHERE SystemMailbox = 'Incorrect_SMTP_Email_Address'
Note: Replace the values from Corrected_SMTP_Email_Address and Incorrect_SMTP_Email_Address using the correct SMTP email address and the incorrect email address from each table.
- Start all Enterprise Vault services.