Problem
"Access Denied" error when attempting to access the Usage.asp page
Error Message
Access denied
Cause
This issue might occur if the authentication configuration in IIS is configured incorrectly for the EnterpriseVault virtual directory, listvaults.asp and usage.asp pages .
Solution
The technology provided by the Windows operating system and the applications involved determine the way queries are passed across IIS servers. Since it is not possible to forward the login credentials using Integrated Windows authentication (IWA), Integrated Windows Authentication has to be unchecked and Basic Authentication enabled for the listvaults.asp and usage.asp pages.
By default, only the Vault Service Account (VSA) has access to the Vault Usage Report because of permission issues between Enterprise Vault (EV) and the Vault Database. Follow these steps to resolve this issue:
On the EV server , open the Internet Information Services (IIS) Manager.
- Expand the EnterpriseVault Virtual Directory.
- Click on Content View (Figure 2)
Figure 2
- Select Usage.asp then click on Switch to Features View (Figure 3)
Figure 3
- Usage.asp will now be listed under the Virtual Directory. Click on this, then double click Authentication (Figure 4)
Figure 4
- Disable Windows authentication and select only Basic authentication.
- Please do the same steps (1-5) for listvaults.asp.
- Close the browser and Delete Temporary Files, Cookies from the browser and then reopen it. The usage.asp page should now be available.