Problem
In the Clearwell documentation it is recommended that the user schedule recurring Active Directory (AD) syncs. The user may discover that a sync worked for a while but is no longer working effectively.
Error Message
Job Statuslog.txt
03/19/2025 02:16:18 Synchronization failed for domain: <YOUR_DOMAIN>. Error: Error in finding domain controller
03/19/2025 02:16:18 Synchronization failed. Please check the job log for errors.
03/19/2025 02:16:18 Synchronization failed with error: Error in doing Directory synchronization - Please check the job log for errors.
TRACE: 03/19/2025 02:16:18 Error: Directory synchronization task failed , Caused by [#430256] Unexpected error: Error in doing Directory synchronization - Error in doing Directory synchronization - Please check the job log for errors.
TRACE: 03/19/2025 02:16:18 Error: Directory synchronization task failed , Caused by [#430256] Unexpected error: Error in doing Directory synchronization - Error in doing Directory synchronization - Please check the job log for errors.
TRACE:com.teneo.esa.icp.custodian.EsiCustodianManagerException: [#430256] Unexpected error: Error in doing Directory synchronization - Error in doing Directory synchronization - Please check the job log for errors.
TRACE:com.teneo.esa.icp.EmployeeManager.startSynchronization(EmployeeManager.java:664)
TRACE:com.teneo.esa.directory.ads.EmployeeSyncJob.run(EmployeeSyncJob.java:98)
TRACE:com.teneo.esa.jobmanager.JobRunner.executeJob(JobRunner.java:152)
TRACE:com.teneo.esa.jobmanager.JobRunner.executeJob(JobRunner.java:137)
TRACE:com.teneo.esa.jobmanager.JobRunner.access$000(JobRunner.java:59)
TRACE:com.teneo.esa.jobmanager.JobRunner$1.call(JobRunner.java:184)
TRACE:com.teneo.esa.common.ThreadPool.Task.cwRun(Task.java:288)
TRACE:com.teneo.esa.common.util.CWRunnableImpl.run(CWRunnableImpl.java:46)
TRACE:com.teneo.esa.common.util.CWThread.run(CWThread.java:88)
Cause
If the admin credentials change, the Clearwell configuration may need to be updated.
Solution
Update the username or password...
- Click System
- Click Directories and Servers
- Click Active Directory
- Click Discovery
- Click the domain that is having the sync issue
- Update/change the username and password fields
- Click on Save