Compliance Accelerator(CA) gets no hits whilst running searches against the content within attachments
Problem
In the CA client, running a search against the content of an attachment gets no hits even though the item has been successfully indexed.
For example, an email has an word document attached which contains the string as "ABCDEFG" and it's sent to the user called "User1" which is a member of the Monitored Employees of the department. Once the journal report of this message has been archived and indexed, an Ad-Hoc search with following criteria is performed in the CA client:
Name: Test Search
Search Type: Immediate
Include items already in review
Date range: Today
Authors and recipients: The department <== internal AND/ OR External to organization
Search terms:
Content (Any of): ABCDEFG
Attachment: Does not matter
Archives To Search: the journal archive contains the archived item
When the search completes no hits are returned.
Error Message
A DTRACE of the EVIndexQueryServer process shows the following query:
Cause
In the CA Client's Configuration tab, Settings sub-tab, Search section is a hidden configuration option for searches named Use Filtered Search. This option controls if top level documents and attachments or just top level documents are searched. By default, this option is set to enable searching the top level documents as well as the contents of attachments to that document. The Use Filtered Search option is controlled by a checkbox in the Value column of the option's row. When unchecked, the behavior of searches with attachments is changed to search only the top level documents and not the contents of attachments.
Solution
To re-enable the ability to search attachments as well as top level documents:
- Launch the CA Client using an account with the application level permissions of Modify System Configuration and View System Configuration. These permissions are granted by default in the Compliance System Admin role which should be assigned to the Vault Service Account and can be assigned to any other Monitored Employee account as appropriate.
- Click on the Configuration tab.
- Click on the Settings sub-tab.
- Hold the Ctrl key down while clicking on the banner where it has Configuration Settings to make the hidden settings visible.
- Expand the Search section.
- Scroll down the list of options to find and select the Use Filtered Search option.
- Click on the check box in the Value column of this option to place a check mark in it.
- Click the Save button in the lower right of the page to save the change.
- Click the OK button in the pop-up dialog box that will appear to acknowledge the need to restart the Customer Background Tasks.
- Close the CA Client.
- Log onto the CA server as the Vault Service Account.
- Restart the Customer's Background Tasks as follows:
- Launch Internet Explorer to the EVBAAdmin site (https://localhost/EVBAAdmin).
- If needed, expand the left panel contents to show the CA customer(s) below the CA server name.
- Select the CA Customer in the left panel to view its properties in the right panel.
- Right click on the CA Customer in the left panel to show the available options.
- Click on the Customer's Background Tasks option. Note that there will be a check mark to the left this option.
- Look in the right panel to view the Current Status section's Customer's tasks: field information as it changes from Running to Stopping to Stopped.
- Right click on the CA Customer in the left panel to show the available options again.
- Click on the Customer's Background Tasks option again. Note that there will not be a check mark to the left of this option this time.
- Look in the right panel to view the Current Status section's Customer's tasks: field information again as it changes from Stopped to Starting to Running.
- After the status is Running, close IE and resume operations as normal as the searches will now include the contents of attachments.