Exchange Server backup using the Application Protection option in a VMware policy exits with Status Code 1

Article: 100014549
Last Published: 2020-12-13
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

 Application State Capture job exits with Status Code 1, resulting in the Exchange Server transaction logs not to be truncated
 

Error Message

20/11/2014 11:59:39 AM - Info nbjm(pid=30914) starting backup job (jobid=17301) for client msexchange.nbulab.local, policy msexchange, schedule FULL
20/11/2014 11:59:39 AM - Info nbjm(pid=30914) requesting MEDIA_SERVER_ONLY resources from RB for backup job (jobid=17301, request id:{96354D5E-7050-11E4-A9BD-D6CB44160827})
20/11/2014 11:59:39 AM - requesting resource 5030-stu
20/11/2014 11:59:39 AM - requesting resource master.nbulab.local.NBU_CLIENT.MAXJOBS.msexchange.nbulab.local
20/11/2014 11:59:39 AM - granted resource master.nbulab.local.NBU_CLIENT.MAXJOBS.msexchange.nbulab.local
20/11/2014 11:59:40 AM - estimated 0 Kbytes needed
20/11/2014 11:59:40 AM - begin Parent Job
20/11/2014 11:59:40 AM - begin Application State Capture, Step By Condition
Status 0
20/11/2014 11:59:40 AM - end Application State Capture, Step By Condition; elapsed time: 0:00:00
20/11/2014 11:59:40 AM - begin Application State Capture, Application State Capture
20/11/2014 12:00:57 PM - Info ascc(pid=4695) Exchange: snapshot preparation successful, with the following information: Found the Symantec VSS Provider installed on this VM.
20/11/2014 12:00:57 PM - Warning ascc(pid=4695) Exchange: snapshot preparation successful, with the following condition: It appears that the Symantec VSS Provider did not execute properly on the previous VM snapshot.
20/11/2014 12:00:57 PM - Info ascc(pid=4695) Exchange: Host msexchange.nbulab.local successfully protected Exchange and cataloged under msexchange.nbulab.local  
Status 1
20/11/2014 12:00:57 PM - end Application State Capture, Application State Capture; elapsed time: 0:01:17
Status 1
20/11/2014 12:00:57 PM - end Parent Job; elapsed time: 0:01:17
the requested operation was partially successful(1)
 
The job was successfully completed, but some files may have been
busy or inaccessible. See the problems report or the client's logs for more details.
 

Cause

It was found that both the Veritas VSS Provider and VMware Tools VSS Provider were both installed on this VM client, causing the snapshot to fail with the above error.

 

Solution

On the VMware backup host, go to:

Install-path\NetBackup\online_util\fi_cntl directory

and remove all existing files that only belong to the VM client, usually has the client name as part of the file name starting as follows:

bpfis.fim.msexchange.nbulab.local_*.

Once files are removed, uninstall both the VMware Tools as well as the Veritas VSS Provider.  This step might require a reboot of the client.

After the server comes back up, install the VMware tools without installing the VMware Volume Shadow Copy Service Support option using Custom Install, then install the Veritas VSS Provider.

The backup should now proceed to complete successfully without further error.

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