Problem
Exporting to PST file fails on Compliance Accelerator (CA) or Discovery Accelerator (DA) with Event ID: 236. All exported items go to the Failed Items folder and an empty PST is created.
CA or DA export runs but fails with Event 236. All exported items go to the Failed Items folder and an empty PST is created.
Error Message
From CA or DA Client:
From CA or DA Event Log:
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 236
Description:
APP AT - Customer ID: 1 - [ExportPST] - Error moving some messages to PST for run 'Export Name' System.ApplicationException. Error in the application.
Cause
PST files can be created but not allowed to have any data added by the use of a registry entry named PSTDisableGrow. If this registry entry is present in the CA or DA server and in the appropriate path for the version of Microsoft Outlook that is installed on the server, CA or DA exports to PST files will create the initial PST file but fail to move any exported items into that PST file.
The PSTDisableGrow registry entry is set in various places in the Registry on the CA or DA server that are dependent upon the version of Microsoft Outlook that is installed. This can be caused by manually editing the registry or through a Group Policy Object (GPO) being incorrectly applied to the Vault Service Account.
The format of GPO examples that will prevent the correct writing of PST files are:
HKEY_CURRENT_USER\Software\Microsoft\Office\Office version\Outlook\PST. (This location is the default location for PSTDisableGrow.)
REG_DWORD 'PSTDisableGrow' is present and the value is 0x00000001 (1)
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\Office version\Outlook\PST.
REG_DWORD 'PSTDisableGrow' is present and the value is 0x00000001 (1)
In the above format examples, replace Office Version with the version number of Outlook that is installed on the server. For example Outlook 2003 is version 11.0 while Outlook 2007 is version 12.0.
Another cause of this issue can be corruption that occurs to the PST file that is to be updated with new items. Such corruption can be caused by antivirus scanning or bad sectors on the disk drive hosting the file.
Solution
Remove the PSTDisableGrow registry entry or set its value to 0 on the CA or DA server. If the PSTDisableGrow registry entry is controlled by a Group Policy, remove the Vault Service Account user from the Group Policy that enables the PSTDisableGrow registry setting.
If the PSTDisableGrow registry value is not present, locate the PST file that is next in line to be updated with items from the export and rename that file (i.e., change its extension from '.pst' to '.bad' and then retry the export.