When selecting the NetBackup Application in the vCenter, the following error is seen “VI SDK invoke exception:java.net.UnknownHostException: ”

Article: 100010883
Last Published: 2014-07-23
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

The NetBackup (NB) plugin in vCenter fails with the error “VI SDK invoke exception: java.net.UnknownHostException: <hostname>” due to a name resolution issue in the environment.

Error Message

Pop-up Error:

VI SDK invoke exception:java.net.UnknownHostException: <vcenter_hostname_here>

vSphere Plugin Error:

Internal error. Please notify the administrator. Take note of any unsaved data, and click here to continue.

Full Error in Logs (catalina.out and nbvcplugin):

[http-9445-6] 22 Jul 2014 15:51:43 ERROR NBvcplugin : Application threw exception
java.rmi.RemoteException: VI SDK invoke exception:java.net.UnknownHostException: <vcenter_hostname_here>

Cause

This issue occurs due to a name resolution problem between the NB Primary server, vCenter server, and NB Plug-in Virtual Machine.

Solution

  1. Verify Name Resolution: Ensure name resolution is functioning correctly on the following hosts:
    • NB Primary Server
    • vCenter/vSphere Server
    • NB Plug-in Virtual Machine
  2. Check Communication: Confirm that each of the above machines can communicate with each other.
  3. Update DNS Configuration: If the domain name server used by the plugin host does not return the Fully Qualified Domain Name (FQDN) during reverse lookups, update the /etc/resolv.conf file with the appropriate domain and search entries.
    • Example:
      # cat /etc/resolv.conf
      domain mydomain.com
      search mydomain.com
      nameserver ###.###.###.###

Additional Tips

  • Ensure that all relevant services are restarted after making changes to the DNS configuration.
  • Verify that there are no firewall rules blocking communication between the hosts.

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