Varonis Auditing Software monitoring Exchange 2010 CAS Servers causing Archiving tasks to fail.

Article: 100008499
Last Published: 2018-03-07
Ratings: 0 0
Product(s): Enterprise Vault

Problem

When archiving Exchange 2010 Mailbox Servers, all archiving tasks are in a failed state.

Depending on the configuration of Enterprise Vault there may be a number of different event ID's logged in the Veritas Enterprise Vault event log.

 

Error Message

All failed tasks experiencing this issue will log the Event ID 3305:

Event ID: 3305
Description: 
The Task '<Archiving Task>' failed to log on to Exchange server '<servername>' using mailbox 'mailbox@domain.com'.
Please ensure that the server is running and that the Vault account has sufficient permissions on the server.
V-437-3305

If a Mailbox Archiving Task is configured then the event ID 2256 will be logged:

Event ID: 2256
Description:
The Archiving task '<Mailbox Archiving Task>' could not be started due to startup errors.
V-437-2256

If a Journal Task is configured then the event ID 2258 will be logged:

Event ID: 2258
Description: 
The Journal Task '<Journaling Task>' could not be started due to startup errors.
V-437-2258

If a Public Folder Task is configured then the event ID 2949 will be logged:

Event ID: 2949
Description:
The Public Folder Task '<Public Folder Task>' could not be started due to startup errors 
V-437-2949

A dtrace of the relevant archiving task (ArchiveTask, JournalTask or PublicFolderTask) shows:
 
{CMailboxHelper::OpenMailbox:#335} Opening message store...
{CMailboxHelper::OpenMailbox:#344} Could not open message store: [0x8004011d]
{CMAPISession::CreateMapiSession:#397} Releasing exclusive profile lock following error [0x8004011d]
 
 

Cause

Varonis Auditing Software prevents Enterprise Vault from establishing connections through Exchange CAS Servers.

 

Solution

Varonis has released hot-fix "Veritas EV Path v5.7.27 (Agent 5.7.20.10)". Please contact Varonis for additional assistance. 

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