A PureDisk (PDDO) or MSDP disk pool is in a "DOWN" (InternalDown) state causing backups to fail with a status code 213 or 2074 or 191
Problem
A PureDisk (PDDO) or a MSDP disk pool is constantly displaying that it is in a "DOWN" state. When executing an `nbdevquery` command, we can confirm the state of the disk volume in question. After trying to change the state of the disk pool to UP, the disk pool remains DOWN.
Command to change the state of the disk pool to "UP":
# nbdevconfig -changestate -stype PureDisk -dp Disk_Pool_name -state UP
Even when attempting to reset the disk pool, it makes no difference - the disk pool remains in a DOWN state.
Command to "Reset" a disk pool:
# nbdevconfig -changestate -stype PureDisk -dp Disk_Pool_name -state RESET
Error Message
Example of output:
# nbdevquery -listdv -stype PureDisk -U
Disk Pool Name : Disk_Pool_Name
Disk Type : PureDisk
Disk Volume Name : PureDiskVolume
Disk Media ID : @aaaas
Total Capacity (GB) : 11612.91
Free Space (GB) : 2660.58
Use% : 77
Status : DOWN
Flag : ReadOnWrite
Flag : AdminUp
Flag : InternalDown
Num Read Mounts : 0
Num Write Mounts : 1
Cur Read Streams : 0
Cur Write Streams : 0
Cause
Possible missing or corrupted ost-plugin configuration file on the media server.
Solution
Verify the existence of the ost-plugin config file on the media server.
Unix:
/usr/openv/lib/ost-plugins/svrname.cfg
Windows:
<Install_path>\NetBackup\bin\ost-plugins\srvrname.cfg
If this file is missing or corrupt (perhaps 0 byte size), perform one of the following:
1. Copy the configuration file from another media server and edit the file to meet this specific media server's information.
or
2. Restore the configuration file from a previous backup of this media server.
Once the file is in place, please restart NetBackup daemons/services. The disk pool should go into an "UP" state, and backups should then complete without a status code 213.