Backups hang at 95% in 'Updating History' state when clients are using a shared backup destination folder.
Problem
If a backup is hanging at 95% during the backup process, and multiple machines are backing up to a shared backup destination, or even the same location but with a unique subfolder, then this issue may be related to a file 'lock' on RPAM_Store.dat which is created/updated during backup operations.
In most cases, the backup is completed but it is recommended to check the validity of the recovery points.
Error Message
No specific error is seen but the backup hangs at 95% in 'Updating History' state.
Cause
At this time, it is believed that a file 'lock' on RPAM_Store.dat is causing this issue.
Solution
There are two types of temporary workarounds for this issue.:
- Manually create a sub-folder for each server, and then point each job to the individual folders. Do not select 'Save backup files to a unique subfolder' (Tasks/Options/General).Manually selecting a specific folder will direct the RPAM_Store.dat file to be created in the specific folder for each client machine.
- RPAM.dll can be unregistered which will also disable the ability to mount a recovery point. If this workaround is used, RPAM.dll can be re-registered when the recovery point needs to be mounted or opened for GRO (Granular Restore Option). To unregister RPAM.DLL, open a command prompt and use the following command: RegSVR32.exe /U C:\Program Files\Common Files\Veritas Shared\rpAccess\Rpam.dll
Once the DLL has been successfully unregistered, the Veritas System Recovery service (VProSvc) will need to be restarted. To re-register, remove /U from the above command.
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
Applies To
This issue is commonly seen when multiple clients are backing up to a shared backup destination and when the backup jobs are overlapping.