Problem
Outlook OST files are not being backed up when a full volume-level backup is done using Veritas System Recovery (VSR).
Cause
VSR uses the Microsoft Volume Shadow Copy Service (VSS) to take a snapshot of the drives for the backup so that the data may be backed up as it looks at a specific point in time. Files that are not part of the VSS snapshot are not backed up by VSR. By default, Microsoft VSS automatically excludes certain files from the VSS snapshot via a FilesNotToSnapshot registry key. Outlook OST files are one such type of file excluded by Microsoft by default.
For more information, please refer to the FilesNotToSnapshot section of the following Microsoft article:
http://msdn.microsoft.com/en-us/library/windows/desktop/bb891959%28v=vs.85%29.aspx
Solution
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
- Run REGEDIT
- Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToSnapshot
- Delete the entry for OutlookOST
- Restart the machine
Note:
The above solution is not recommended by Veritas and is only provided as a workaround to the issue. If you are in any doubt about making the above changes, Veritas recommends that you contact Microsoft Technical Support for guidance.