The user folders are not created even after the extended storage was successfully configured in Desktop and Laptop Option (DLO)
Problem
User folders are not created in NUDF (Network User Data Folder) location of Extended Storage even after its successful configuration.
Error Message
In the DLOConsoleu.Log file it shows the below message:
65, dloconsoleu.exe, 2688:, T>, adocommand.cpp( 962 ), executing ADO command: { ? = call sp_shadow_create_dir(?, ?, ?, ?) }
05/09/23, 16:15:36:65, dloconsoleu.exe, 2688:, G>, adocommand.cpp( 976 ), parameter( 0 ): @RETURN_VALUE - adInteger, size: 0 - adParamReturnValue
05/09/23, 16:15:36:65, dloconsoleu.exe, 2688:, G>, adocommand.cpp( 976 ), parameter( 1 ): @UNCPath - adVarWChar, size: 102 - adParamInput
05/09/23, 16:15:36:65, dloconsoleu.exe, 2688:, G>, adocommand.cpp( 976 ), parameter( 2 ): @AccountName - adVarWChar, size: 98 - adParamInput
05/09/23, 16:15:36:65, dloconsoleu.exe, 2688:, G>, adocommand.cpp( 976 ), parameter( 3 ): @DomainFullGroupName - adVarWChar, size: 1 - adParamInput
05/09/23, 16:15:36:66, dloconsoleu.exe, 2688:, G>, adocommand.cpp( 976 ), parameter( 4 ): @DomainLimitedGroupName - adVarWChar, size: 1 - adParamInput
05/09/23, 16:15:36:236, dloconsoleu.exe, 2688:, E>, ConfigShareObject.cpp( 1186 ), Failed to update the tables for secondary storage: Caught unknown exception
05/09/23, 16:15:36:237, dloconsoleu.exe, 2688:, T>, adocommand.cpp( 1128 ), executing ADO command: { ? = call IsAdmin }
Cause
DLO tries to call the LoadAccount windows API to identify the DC by passing the domain user account to LookUpAccountName API (another Windows API) which fails to return the SID and domain name of the account resulting in the user folder not getting created.
Solution
A supported hotfix has been made available for this issue. Please contact Veritas Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.
Veritas Technologies LLC currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests. Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.