Problem
Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA) Exports fail with error referencing duplicate endpoints and error code 0x800706cc
, as listed below. Some or all items in the Export may show this error when reviewing the Export details.
It is possible that running a Re-Try on an Export to reprocess the failed items may result in those items succeeding or may result in the same errors. Repeatedly running Re-Try on the Export would likely result in all items being eventually Exported.
A review of the EV Event Logs on the EV Storage Service server(s) may show entries as listed below.
Note
It may be possible the Event Logs do not show any such entries if the port used is in the configured range of the Default Protocols. To view the port ranges:
1. Start the Component Services app using one of the following methods:
1.1. Click the Start button, type Component Services
and click the Component Services desktop app.
1.2. Go to Start | Run | comexp.msc
[Enter]
1.3. Go to Start | Run | dcomcnfg.exe
[Enter]
2. Expand Console Root | Component Services | Computers | Right-click My Computer | Properties | Default Protocols.
3. Check any listed connections by double-clicking the connection or clicking the connection then clicking Properties.
4. Any configured port ranges will be listed in the Properties for COM Internet Services window.
Error Message
Error seen in the Accelerator Client:
Failed to retrieve: An internal failure occurred. Internal Error: 'The endpoint is a duplicate. (0x800706cc)'.
The following Events may be seen in the EV Event Logs on the EV Storage Service server(s).
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Event ID: 10006
Task Category: None
Level: Error
Keywords: Classic
Description:
DCOM got error "2147944140" from the computer <EV Storage server> when attempting to activate the server:
{GUID of EV server instance}
V-437-10006
Log Name: Application
Source: Microsoft-Windows-COMRuntime
Event ID: 18205
Task Category: None
Level: Error
Keywords: Classic
Description:
DCOM server attempted to listen on an invalid endpoint. Protocol Sequence: ncacn_ip_tcp Endpoint: <Port number> Flags: 0
V-437-18205
Cause
The issue is caused by a lack of available ports as determined by the DCOM Component level restrictions on the StorageOnlineOPNS (SOPNS) Component on the EV Server. The SOPNS DCOM Component requires multiple ports to be available to allow for multi-threaded operations. The multi-threaded entries for the StorageOnlineOPNS processes can be seen in the Task Manager. To determine what Process IDs (PIDs) and what ports may be in use by the StorageOnlineOPNS processes:
1. Right-click the Task Bar on the EV Storage Server | Task Manager | Details.
2. Sort by Name and note the PIDs of all StorageOnlineOpns.exe processes.
3. Open an Administrative Command Prompt on the EV Storage Server.
4. Edit the following command to replace 1234, 5678
with the PIDs of the StorageOnlineOpns processes. Note the delimiter between each entry is a space and the entire string must be enclosed in straight double quotes. Add as many entries as needed, making sure to the enclose the space-delimited string in straight double quotes:
netstat -aon | findstr "1234 5678"
5. Execute the command and check the last column for each row to determine the port being used.
Compare the list of ports with the port referenced in any Event ID 18205 entries. If found to be the same, it is possible the ports have been restricted in the environment.
To view any port restrictions on the StorageOnlineOPNS DCOM Component:
1. Start the Component Services app using one of the following methods:
1.1. Click the Start button, type Component Services
and click the Component Services desktop app.
1.2. Go to Start | Run | comexp.msc
[Enter]
1.3. Go to Start | Run | dcomcnfg.exe
[Enter]
2. Expand Console Root | Component Services | Computers | My Computer | DCOM Config | Right-click the StorageOnlineOpns Component | Properties | Endpoints.
3. Check the Properties of any listed protocols. If the 'Connection-oriented TCP/IP' Protocol Sequence is configured, check the settings to see if the 'Use static endpoint' option was selected. If so, verify the port listed is the same as referenced in any Event ID 18205 entries.
If any static entries are found, the onsite network administration team will need to determine why the entry was added and if the entry is truly needed. StorageOnlineOPNS will not function as a multi-threaded process if a single port is configured and the Export issues seen are expected in such a configuration.
Note
If the only clickable button is Add and the Properties button is greyed out, the protocols and endpoints should be at their default values
Solution
In order to resolve this issue, the StorageOnlineOPNS process must run as a multi-threaded process and cannot be restricted to a single port. Once the onsite network administration team has reviewed the StorageOnlineOPNS DCOM Component settings and has agreed to change the settings (after having recorded the current settings), either Remove the 'Connection-oriented TCP/IP' Protocol Sequence entry, or reconfigure it to use one of the following options:
- Use default endpoints
- Use intranet range of dynamic endpoints
- Use internet range of dynamic endpoints
Once reconfigured and the changes saved, restart the Enterprise Vault Storage Service on the EV Storage Service server. Note, this process may need to be done on all EV Storage Service serves. Once all EV Storage Service servers have their StorageOnlineOPNA DCOM Components correctly configured, the Accelerator Exports can be re-tried to confirm expected functionality.