在Microsoft Windows磁盘管理中显示的驱动器,在System Recovery中没有出现。

文章: 100059015
上次发布时间: 2023-07-21
评级: 0 0
产品: System Recovery

Problem

在System Recovery控制台中, 没有显示C:\ 驱动器或其它驱动器。

Error Message

PartInfo.txt文件,可能有以下警告:

  • WARNING: Partition above extends beyond end of disk   
  • WARNING: Partition above overlaps with primary partition 
  • WARNING: Invalid Begin CHS values in partition above.
  • WARNING: Begin CHS does not match start sector LBA in partition above.
  • WARNING: Invalid End CHS values in partition above.
  • WARNING: End CHS does not match calculated end LBA in partition above.                 
  • WARNING: Logical partition above begins outside of extended partition.
  • WARNING: Logical partition above ends outside of extended partition
  • WARNING: GPT Header Check Sum is invalid.
  • WARNING: GPT Partition Array Check Sum is invalid.

注意:以上只是可能在PartInfo.txt中看到的分区表错误的示例。其他“警告”消息也可能存在.

Cause

导致分区表项错误的原因包括但不限于:

1. 在RAID配置下,起始CHS与起始扇区LBA不匹配

2. 分区大小超出了磁盘的末端


BESR和SSR是基于扇区的备份实用程序,它们依赖于完全准确的分区信息。这确保了可靠、准确的备份。如果在任何分区上检测到错误,该卷将不会在界面中显示该卷,因为它不适合备份。恢复不准确的卷可能导致数据丢失或损坏。这是为保护您的数据而设计的。

Solution

如果在图形用户界面(GUI)中,没有显示卷作为要备份的驱动器,请首先双击以下位置的PartInfo.exe。这将在同一位置创建一个partinfo.txt文件。打开这个文件,找到上面的错误:

对于32位系统:

C:\Program Files\veritas\Backup Exec System Recovery\Utility

C:\Program Files\veritas\veritas System Recovery\Utility

对于64位系统:

C:\Program Files(x86)\veritas\Backup Exec System Recovery\Utility

C:\Program Files(x86)\veritas\veritas System Recovery\Utility

SSR 2013及以后:

C:\Program Files\veritas\veritas System Recovery\Utility
 

解决驱动器可见的问题,请执行以下操作:

1)重新启动计算机,进入系统BIOS。检查驱动器设置的准确性。确保您可以正确检测驱动器。如果需要,让BIOS重新检测所需的驱动器。请与计算机的系统或主板制造商联系,以获得进一步的帮助和帮助。

2)如果有分区位于NAS或SAN设备上,请确保所有控制器都使用最新的固件和驱动程序。

3)关闭服务器,并重新初始化设备。

4)如果您的计算机运行的系统是Microsoft Windows Vista、Windows 7、Windows 2008或更高版本,请打开Windows磁盘管理控制台。

5)右键单击,选择“收缩卷…”

5)停止System Recovery和SymTrackService服务。

6)减小卷大小(以MB为单位)。这可能会使分区表边界恢复到合规性。此步骤后可能需要重新启动。重启后尝试重新创建备份。检查驱动器的可见性。

7)收缩卷5Gb (5000Mb),点击收缩:

8)启动System Recovery服务,然后启动SymTrackService服务。

9)打开SSR或BESR控制台,查看驱动器是否可见。如果是,请创建备份任务。(注意:在创建备份作业期间,向导将提示您包含完成系统恢复所必需的其他隐藏卷。隐藏卷和受保护卷不能通过磁盘管理收缩。)

10)如果驱动器仍然不可见,重新运行PartInfo.txt文件。如果仍然出现警告,请使用收缩卷…(尝试再收缩1Gb - 5Gb.)选项下的Windows磁盘管理,直到在PartInfo.txt文件中看不到警告。

11)如果存在旧的BESR或SSR备份,则启动到SRD。

12)删除存在错误的卷,并从SRD内恢复它们。

13)如果驱动器仍然没有检测到,唯一的解决方案是使用基于文件的备份,使用Microsoft Windows或backup Exec for Windows server (BEWS)的备份功能备份数据。备份完数据后,应该删除分区,然后重建分区。

如果分区(需要重建)包含系统驱动器,则需要重新安装操作系统。

15)如果使用Windows 2003或其他不支持收缩功能的操作系统,第三方实用程序可能允许您执行此操作。
注意:

当分区被错误地创建或更改时,或者当第三方实用程序影响分区时,就会发生分区错误。Windows磁盘管理器不一定能识别磁盘分区为MBR或GPT;这两种磁盘类型通常都被列为“基本”。因此,即使存在分区错误,Windows也能继续工作。

此内容是否有用?