検索クエリーを入力してください
すべてのサポートコンテンツとコミュニティコンテンツを検索...
記事: 100058682
最終公開日: 2023-08-10
評価: 0 0
製品: Desktop Laptop Option
問題
DLO エージェントが DLO 管理サーバーに接続できないというメッセージが現れたとき、接続を確認する際にこの操作を実施し、DLO データベースに接続可能かどうかを確認します。
原因
この問題は一般的に、データベース参照に正しいエントリが含まれていない場合や、SQL データベース (DLO) で情報を開いたりクエリするための書き込みする権限が十分ではない場合、または Microsoft OLE DB Driver for SQL Server コネクタがインストールされていないか正しくインストールされていない場合により発生します。
解決策
ODBC データソースを使用して、DLO エージェントと DLO データベース間の名前付きパイプ接続をテストします。
Windows の [スタート] ボタンをクリックし、[ODBC Data] と入力して、ODBC Data Sources (32-bit) の検索を開始します。[管理者として実行] オプションを選択します。
[ユーザー DSN] タブで [追加] をクリックし、[SQL Server] を選択して [完了] をクリックします。
SQL Server への新しいデータ ソースの名前 ("Test" など) を入力し、SQL Server とインスタンス名を入力して、[次へ] をクリックします。
[クライアント構成] をクリックし、[Named Pipes] を選択して、[OK]、[次へ] の順にクリックします。
既定のデータベースを [DLO] に変更し、[次へ] と [完了] をクリックします。
[データ ソースのテスト] をクリックすると、クライアントからデータベースサーバーへの Named Pipes 接続がテストされます。