NetBackup install or upgrade fails during master_server_name check

記事: 100047165
最終公開日: 2020-04-10
評価: 0 0
製品: Appliances, NetBackup & Alta Data Protection

Problem

Inspection of the hostname that is used to identify the master server, has found an underscore (_) character.  A situation that must be corrected before the install or upgrade is allowed to continue.  For new install, the proposed hostname for the master server did not pass inspection.  For upgrade, the first SERVER entry in the NetBackup configuration, bp.conf file or registry did not pass inspection.  This check fails so that situation can be corrected before the install or upgrade proceeds.
 

This checks runs on master servers (standalone and active/inactive cluster nodes), media servers, and clients. This  check is applicable when either installing a Windows master server, or upgrading to NetBackup version 8.0 or higher from NetBackup version 7.7.3 or higher on any platform.

Error Message

not ok master_server_name: Master server <hostname> has underscores in it, which is not RFC compliant.
not ok master_server_name: Master server <hostname> in bp.conf has underscores in the hostname, which is not RFC compliant.not ok master_server_name: Master server <hostname> in registry has underscores in the hostname, which is not RFC compliant.

 
The above error message indicates that either the proposed master server hostname, or the first entry for SERVER, contains an underscore.
 
not ok master_server_name: There is no entry found for SERVER in bp.conf.
not ok master_server_name: There is no entry found for SERVER in registry.

 
The above error indicates that the required SERVER entry was not present and could not be checked for underscores.

Cause

This has been a challenging topic for more than 20 years.

The use of underscore characters within hostnames has always been discouraged per RFC 952 (DOD Internet Host Table Specification) and RFC 1123 (Requirements for Internet Hosts - Application and Support) standards. 

But, before utilizing NetBackup, some customers already have hostnames which contain underscores.  Because many features of NetBackup operate successfully, even when underscores are present, NetBackup 3/4/5/6/7 do not explicitly prevent the use of underscores.  However, starting with NetBackup 8.0, third-party components that are part of the NetBackup master server have this constraint.

Accordingly, during upgrade, NetBackup now checks for standards violations and requires them to be resolved before performing upgrades.

Solution

For new installs, configure name services to use a hostname or hostname alias for the master server that does not contain underscores, and then use that hostname when installing and configuring NetBackup. 

For upgrades, the master server hostname may need to be changed, please contact Veritas Consulting Services for assistance.

In some cases, remote hosts may be able to use a network hostname alias - that does not contain underscores - when connecting to or accepting connections from the master server. 

  • Update the name services configuration for forward and reverse resolution of the new hostname and associated IP address.
  • Modify the NetBackup configuration to utilize the new hostname for the master server.
  • Clear the NetBackup host cache so the new hostname and IP resolutions are available to NetBackup.
  • Be aware that CA and Host ID certificates may need to be reissued depending on the hostnames by which the master server was previously known and configured.

 

Was this content helpful?