After Flex NetBackup instance upgrade, MSDP-C disk pool down and connection refused errors are observed.

After Flex NetBackup instance upgrade, MSDP-C disk pool down and connection refused errors are observed.

Article: 100073515
Last Published: 2025-03-26
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection, Appliances

Problem

After a Flex NetBackup instance upgrade, the MSDP-C disk pool is down and various related NetBackup job failures (such as status 84, status 191) are returned.

Error Message

The ocsd_storage logs report connection refused when attempting to connect to the cloud provider endpoint.

Test curl commands attempting to connect to the cloud provider endpoint may also report connection refused.
 

Cause

The 'connection refused' message can result from many factors, such as a firewall blocking Internet access. But if it is known that the Flex NetBackup instance is configured for multiple networks, the Flex instance upgrade may have changed the Default IPv4 gateway interface.

Solution

To verify the gateway interface and update it if needed, perform the following:

  1. From the System topology page of the Flex Appliance Console, navigate to the Application instances section.
  2. Locate the instance to be edited. Select the instance and click Stop (the Default IPv4 gateway interface can only be changed when the instance is offline).
  3. Click on the instance name to open the instance details page.
  4. At the top of the details page, click Edit network.
  5. Click the drop-down menu to the right of Default IPv4 gateway interface and select the correct gateway interface.
  6. Back in Application instances, select the instance and click Start.

References

JIRA : FLEX-29679

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