No valid Windows Global User credentials found for IP customization

Article: 100059200
Last Published: 2023-08-08
Ratings: 1 0
Product(s): Resiliency Platform

Problem

No valid Windows Global User credentials found for IP customization

Error Message

Probe Risk on Resilience Group:

No valid Windows Global User credentials found for IP customization

Cause

This can be caused by several things.

  1. Windows Global User not defined in Veritas Resiliency Platform (VRP.)
  2. Windows Global User account is not cached on the virtual machine.
  3. User Account Control (UAC) settings are blocking the Windows Global User account from changing the IP address.

Solution

Cause # 1 - Windows Global User not defined in VRP

Confirm that a Windows Global User is defined in VRP.

  • In the VRP GUI, go to Settings > User Management > Windows Global User.

If no user is in the list, add one by clicking the Configure User button and provide the user details requested.

Cause # 2 - Windows Global User account is not cached on the virtual machine.

Confirm that the user account defined as the Windows Global User has logged into the Windows virtual machine (VM) and that it's account is cached so the user can log into the VM without access to a domain controller on the network.

  • Log into the VM with an account different than the user account defined as the Windows Global User.
  • Check in Windows explorer to see if there is a folder for the user account defined as the Windows Global User in the C:\Users folder. 

If the folder does not exist, then the user account may not have ever logged into the VM or user account caching has been disabled in the domain.

Cause # 3 -  UAC settings are blocking the Windows Global User account from changing the IP address.

Check if UAC settings are blocking IP address changes by the Windows Global User account.

  • Log into the VM with the Windows Global User account.
  • Open Network Connections.
  • Right click on the NIC and select Properties.

If UAC is enabled, you will be propted by UAC to allow the operation or to provide an administrator account and password to continue.

Possible solutions to UAC being enabled:

  • Disable UAC settings on the VM.
  • Reconfigure the Resiliency Group IP Customization setting to use the VRP IP Customization Service. Highlights of the VRP IP Customization Service.
  1. This service runs as the Local System account so that it can bypass UAC settings. 
  2. The service is configured to start automatically. 
  3. During start of the service, it checks if the IP address needs to be changed. 
  4. If the service changes the IP, the service reboots the nodes. 
  5. If the IP does not need to be changed, then the service stops so that the service consumes no system resource after initial startup and IP change.

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