Problem:
The NetBackup client upgrade precheck fails at the localhost_check phase.
Error Message
The host name [myhostname] does not resolve to an IP address assigned to a network interface on this host.
The host name [myhostname] does not resolve to an IP address.
The host name [myhostname] does not respond to a ping command.
This test runs for upgrades if the installed NetBackup version is 7.7 or later.
For NetBackup to function properly, the host name [localhost] must resolve to an IP address, respond to a ping command, and be a network interface on the local system.
Refer to the following article for more details:
https://www.veritas.com/support/en_US/article.100045507
Cause
bpclntcmd.exe was found to be corrupt. The size of the binary was 0 bytes and if the command bpclntcmd.exe was run from an admin command prompt, it shows "Access Denied
"
Solution
To resolve the issue, copy the bpclntcmd.exe file from any other client running the same version of NetBackup (and the same OS) and retry the upgrade. It should be successful.