Incorrect error message appears after adding Active Directory or LDAP users

Article: 100049282
Last Published: 2021-01-07
Ratings: 1 0
Product(s): Appliances

Problem

After attempting to add a new Active Directory (AD) or LDAP user, the following message may appear.

Error Message

nbappliance.LDAP> Users Add testuser 

The user name that you have entered is not valid. Enter a valid user name. 

Command failed! 

nbappliance.LDAP> 

Cause

The following issues can cause this problem:

  • The AD/LDAP server is either down or not reachable from the appliance.
  • The user name does not exist on the AD/LDAP server.

Solution

Try to ping the AD/LDAP server with the following command: Main > Network > Ping

If the command fails, do the following: 

  • Verify whether the AD/LDAP server is down. If it is, wait for it to come back online and try the operation again. 
  • Resolve any network configuration changes (such as firewall settings) that could prevent the appliance from pinging the AD/LDAP server. 

If command is successful, verify whether the user name exists on your AD/LDAP server. If the user name exists, contact Veritas Support for assistance to resolve the issue.

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