VxUpdate deployment policy fails to update NetBackup client due to Stop On Error Operation Status 7223

Article: 100048198
Last Published: 2020-09-09
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

While running VxUpdate deployment policy to update NetBackup clients, a client machine is failing to upgrade NetBackup and is reporting a Stop on Error due to Operation Status 7223 (The requested operation is not supported.); which indicates an upgrade attempt was made to operate on an unsupported product or platform.

Error Message

Deployment Job Detailed Status:

Aug 12, 2020 1:52:12 PM - Info nbjm (pid=2690) starting deployment job (jobid=772812) for client nbclient, policy Upgrade77xTo8x, schedule Upgrade
Aug 12, 2020 1:52:12 PM - Info nbjm (pid=2690) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=772812, request id:{EC04142C-DC74-11EA-8DCD-6BB4791D6FC7})
Aug 12, 2020 1:52:12 PM - requesting resource  nbmaster.NBU_CLIENT.MAXJOBS.Upgrade77xTo8x.Upgrade
Aug 12, 2020 1:52:12 PM - Info nbrb (pid=2620) Limit has been reached for the logical resource nbmaster.NBU_CLIENT.MAXJOBS.Upgrade77xTo8x.Upgrade
Aug 12, 2020 2:06:00 PM - granted resource  nbmaster.NBU_CLIENT.MAXJOBS.Upgrade77xTo8x.Upgrade
Aug 12, 2020 2:06:01 PM - begin Child Job
Aug 12, 2020 2:06:01 PM - begin Deployment: Step By Condition
Operation Status: 0
Aug 12, 2020 2:06:01 PM - end Deployment: Step By Condition; elapsed time 0:00:00
Aug 12, 2020 2:06:01 PM - begin Deployment: Deployment Stage Agent
Aug 12, 2020 2:06:01 PM - Info RUNCMD (pid=7049) started
Aug 12, 2020 2:06:01 PM - Info RUNCMD (pid=7049) VxUpdate does not support server upgrades.
Aug 12, 2020 2:06:01 PM - Info RUNCMD (pid=7049) exiting with status: 7223
Operation Status: 7223
Aug 12, 2020 2:06:01 PM - end Deployment: Deployment Stage Agent; elapsed time 0:00:00
Aug 12, 2020 2:06:01 PM - begin Deployment: Stop On Error
Operation Status: 0
Aug 12, 2020 2:06:01 PM - end Deployment: Stop On Error; elapsed time 0:00:00
Operation Status: 7223
Aug 12, 2020 2:06:01 PM - end Child Job; elapsed time 0:00:00
The requested operation is not supported.  (7223)

Cause

VxUpdate is trying to upgrade the NetBackup client software and it is being informed on the client side that this might have NetBackup Server binaries installed.

Upon checking the NetBackup Administration Console, under Host Properties > Clients, the problem client (nbclient) was showing as a media server role, instead of a client role.

  • The NetBackup version was checked; it was version 7.7 or higher.
  • The operating system was checked; it was a supported platform.
  • The software binaries were checked; it was a supported product.
    • The NetBackup Server binaries were not installed; no admincmd directory was present.
  • The NetBackup configuration (bp.conf file) was checked...
    • Problem: The client had itself listed as an authorized server in the Server list.
    • Example:
      $ grep nbclient /usr/openv/netbackup/bp.conf
      SERVER = nbclient.local  <<== This entry should be removed.
      CLIENT_NAME = nbclient

Solution

Ensure the NetBackup client being upgraded, is only configured as a client, and there are no superfluous entries in the NetBackup configuration.

Steps to resolve the issue:

  1. On the NetBackup Client, remove the SERVER or MEDIA_SERVER entries, which contain same name or aliases of the CLIENT_NAME.
  2. After the entry is removed from the NetBackup, restart the NetBackup Client services.
    • Note: At this point, after refreshing the NetBackup Administration Console, the client machine role updated from media server role to client role, under Host Properties > Clients.
  3. Then, retry the VxUpdate policy to upgrade the client, which should complete successfully and the updated client version should be reflected in the Administration Console after another refresh.

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