DFSR folder backups are taking longer to complete after updating a Windows client to NetBackup 8.1 or higher.

Article: 100042299
Last Published: 2022-06-24
Ratings: 0 1
Product(s): NetBackup

Problem

After upgrading a Windows client to NetBackup 8.1 or higher, DFSR backups are taking significantly longer to complete.  Backups that used to take perhaps 10 minutes to run are now taking several hours to complete. 

 

Error Message

No error messages are reported.  The DFSR backups are simply much slower after the upgrade to NetBackup 8.1 or higher.

Reviewing a bpbkar log from the client helps to show delays in the processing.  In this example, note the 20 second delay for each file being read:

(the bpbkar log resides at <install dir>\netbackup\logs\bpbkar on the Windows client)

03:46:23.198 [2360.8748] <4> dos_backup::tfs_findfirst: INF - unable to find first file: 'C:\DfsRoots\Home$\tmp1\'
03:46:43.088 [2360.2412] <2> dtcp_read: TCP - success: recv socket (1384), 4 of 4 bytes

 

Cause

There is a specific mount point of type DFS(R) which Windows is returning to NetBackup. Earlier versions of NetBackup were not checking for the mount point type and instead called it "Unknown." But in those previous versions, NetBackup was processing the mount point correctly.  

In NetBackup 8.1, a change was made to recognize the DFS(R) mount point, but unfortunately this introduced significant delays in reading the files.  

 

Solution

An Emergency Engineering Binary (EEB) bundle containing a fix for this issue for NetBackup 8.1 is available by contacting Veritas technical support, referencing this document ID and the following etrack number(s):

  • 8.1: Etrack 3938993
  • 8.1.1: Etrack 3942306
  • 8.1.2:Etrack 3965078
  • 8.2: Etrack 3993555
  • 8.3 and above : Issue is resolved

The fix updates bpbkar32.exe.  After applying the EEB, NetBackup performance of backups should return to levels seen with the releases prior to 8.1.

Veritas Technologies LLC has acknowledged that the above-mentioned issue (Etrack 3938994) is present in the NetBackup 8.1 release. Veritas Technologies LLC is committed to product quality and satisfied customers.

 

References

Etrack : 3938994

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