Problem
Backup Exec upgrade does not complete successfully and rolls back at the end of installation
Error Message
Errors observed in the installation log:
: In BE_InstallServices::ComputerName= <Server-Name>.
: In BE_InstallServices::SetServiceUser= <BESA-Account-Name>.
: In BE_InstallServices::W2kFlag= True.
: In BE_InstallServices::InstallMode= 0.
: In BE_InstallServices::ServicePath= "C:\Program Files\Symantec\Backup Exec\BackupExecManagementService.exe".
: In BE_InstallServices::IsCluster::SVCReset= True.
: In BE_InstallServices::UserCreds::W2k8 = 0.
: In BE_InstallServices::ServicePath= "C:\Program Files\Symantec\Backup Exec\bengine.exe".
: In BE_InstallServices::IsCluster::SVCReset= True.
: In BE_InstallServices::UserCreds::W2k8 = 0.
: In BE_InstallServices::ServicePath= "C:\Program Files\Symantec\Backup Exec\beserver.exe".
: In BE_InstallServices::IsCluster::SVCReset= True.
: In BE_InstallServices::UserCreds::W2k8 = 87.
: In BE_InstallServices::ReturnCode= 87.
+ : FATAL ERROR: BEMSI;InstallManager.dll;InstallManager.cpp;ConfigInstall_MSI()-InstallBEServices;87
+ : V-225-116: Error installing BE services ***To search for information about this error, click here
Cause
All Backup Exec services were running under Local System Account.
Solution
By default, only the Backup Exec Remote Agent and Backup Exec Error Recording services should run under Local System Account. The remaining Backup Exec services should run under Backup Exec Account Service (BESA).
In the above example, the log reoprts that BESA couldn't run the beserver.exe (Backup Exec Server) service.
- Ensure that the Backup Exec services are running on correct accounts:
- on Local System:
Backup Exec Error Recording Service
Backup Exec Remote Agent for Windows
- on BESA:
Backup Exec Agent Browser
Backup Exec Device & Media Service
Backup Exec Job Engine
Backup Exec Management Service
Backup Exec Server
Note: After changing the account, all Backup Exec services should be restarted.
- After restarting the services, re-run the upgrade of Backup Exec