Cannot connect to the Veritas System Recovery agent on the remote server from the System Recovery console
Problem
When trying to connect to a remote Veritas System Recovery (VSR) agent from VSR cosole getting error
Error Message
This program is unable to connect and communicate with the Veritas System Recovery Service on <Server name or IP Address>
Cause
This issue occurs because the Default Component Object Model (DCOM) permissions.
Solution
Confirm the permissions issue by enabling the DCOM error logging through registry as below:
1. Click Start, click Run, type regedit, and then click OK.
2. Locate the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole registry subkey.
3. Right-click the Ole value, point to New, and then click DWORD Value.
4. Type ActivationFailureLoggingLevel, and then press ENTER. Double-click ActivationFailureLoggingLevel, type 1 in the Value data box, and then click OK.
5. Right-click the Ole value, point to New, and then click DWORD Value.
6. Type CallFailureLoggingLevel, and then press ENTER. Double-click CallFailureLoggingLevel, type 1 in the Value data box, and then click OK.
7. Restart the DCOM program, and then examine the System log and the Application log for DCOM errors.
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
Resolve the permissions issue by following the steps as below:
1. Click Start > Run. Type DCOMCNFG and click OK.
2. Expand the Component Services\Computers container.
3. Right-click My Computer, and then click Properties.
4. On the COM Security tab, click Edit Limits in the Launch and Activation Permissions area or in the Remote Activation area. The area depends on where the issue occurs.
5. Click the account that is specified in the event log error, and then click Allow for the Remote Access permissions or for the Remote Launch and Remote Activation permissions.
6. Click OK two times to accept the changes. Then, try to use the program that uses DCOM.