NetBackup does not utilize a tape drive and fails with error "EMM status: No drives are available"

Article: 100021335
Last Published: 2014-02-19
Ratings: 1 1
Product(s): NetBackup & Alta Data Protection

Problem

Problem occurs when NetBackup fails to utilize the tape drive and tape drives show available in device monitor.

Error Message

NBU status: 800, EMM status: No drives are available

Cause

Run /usr/openv/volmgr/bin/tpconfig -emm_dev_list

For drive in question see Flags attribute:
Flags:                         1073741952
The drives flag was 1073741952 which in hexadecimal is 40000080

From LTItypes.h:
#define MM_RESTART_LTID 0x40000000 /* a device configuration change has occurred on the emm server, and this host's daemons should be restarted */
 

Note that the values are different, 0x40000080 for the drive flag is different from the value defined for MM_RESTART_LTID 0x40000000 (there is no 8 in the second to the last digit). Even though the values are different, the comparison is done based on the first bit 0x4 and as they are the same for both values, the flag 1073741952 is considered as MM_RESTART_LTID.

 

Solution

In order to resolve this issue clear the flag or restart ltid on all media servers sharing the tape drive if vmoprcmd does not clear the flag.

Perform following command to clear the flag on all media servers:

vmoprcmd -reset_ltid_restarted_bit -h <host name>

Location :
Unix : /usr/openv/volmgr/bin/
Windows : Program Files\Veritas\Volmgr\bin

 

In case of a large number of media servers, the above command can be run as part of the script. The following is an example of such a script that uses all media servers from the tpconfig -emm_dev_list output -

tpconfig -emm_dev_list | grep Media | sort -u | awk '{print $3}' | while read ms; do  vmoprcmd -reset_ltid_restarted_bit -h $ms; done

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