Updated license not seen in Data Insight licensing

Article: 100014998
Last Published: 2025-03-28
Ratings: 0 1
Product(s): Data Insight

Problem

Unable to apply a license via the Data Insight Console.

Or 

New license details are not displayed in the Data Insight Console.

Error Message

A License is invalid or expired error will be displayed if you are unable to add the license (even if the license is still valid).

There is no error shown if the license is added but missing the updated details

Cause

The problem happens because of stale license files OR expired license files in the <DATADIR>\DataInsight\data\lic folder on the Management Server.

 

Solution

On the Management Server:

  1. Stop the DataInsightWeb service.
  2. Delete all files in the <DATADIR>\DataInsight\data\lic folder and paste to a TEMP folder.
  3. Start the DataInsightWeb service.
  4. Once the console is accessible after the service restarts, login to Data Insight and re-apply the license.

 

 

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