When users access Enterprise Vault Search using Internet Explorer they receive an error: "Your session has expired due to an extended period of inactivity”.
Problem
Internet Explorer users receive error Your session has expired due to an extended period of inactivity in Enterprise Vault Search. Other browsers, such as Chrome or Firefox, are unaffected by the problem.
Error Message
Figure 1: Your session has expired due to an extended period of inactivity pop-up error screen shot.
DTrace of W3WP process:EV-H {EVS.EN_US} Client Credential TypeWindows
EV-H {EVS.EN_US} Client Credential TypeBasic
EV~E |Event ID: 41521 Enterprise Vault Search cannot perform certain operations. Check that all Enterprise Vault services are running.
EV-H {EVS.EN_US} Exception: SessionExpiredError Info:Inside IErrorHandler.HandleError() || Diag: Type:System.Exception ST: at Symantec.EV.Search.Client.Host.PluginService.ClientDataService..ctor()| at CreateSymantec.EV.Search.Client.Host.PluginService.ClientDataService()| at System.ServiceModel.Dispatcher.InstanceBehavior.InstanceProvider.GetInstance(InstanceContext instanceContext, Message message)| at System.ServiceModel.Dispatcher.InstanceBehavior.GetInstance(InstanceContext instanceContext, Message request)|
V-437-41521
Possible secondary pop-up error:
Your search request failed. Wait and try again. If problem persists, contact your Enterprise Vault administrator.
Possible secondary Event ID 41510:
"Error: The message could not be dispatched because the service at the endpoint address 'net.tcp//localhost/EnterpriseVaultAPI/search/soapsearch.svc' is unavailable for the protocol of the address.
V-437-41510
Cause
Following three scenarios have been identified that can cause this behavior:
- The value of registry 1A10 in the Restricted Sites Zone (Zone 4) is NOT set to 3 (Block all cookies).
- The DefaultWebApp URL of Enterprise Vault environment includes the 'underscore' character in server/domain name.).
- On Enterprise Vault server logged in as VSA, the EV Search works as expected. When logged into a workstation as a user, the EV Search also works when opening the parent folder, such as the Inbox, but when clicking a subfolder immediately pops up a message saying "Y
our search request failed. Wait and try again. If problem persists, contact your Enterprise Vault administrator.
" Event 41510 is thrown saying "Error: The message could not be dispatched because the service at the endpoint address 'net.tcp//localhost/EnterpriseVaultAPI/search/soapsearch.svc' is unavailable for the protocol of the address.
" This issue began after an upgrade and was resolved by setting the alternative solution below where UseRestrictedSecurity is changed to 0.
Solution
- In the affected client computer, set value 3 (Block all cookies) for Restricted Site Zone.
Key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4
Value Name: 1A10
Value Data: 3
Alternatively, if all users are using Internet Explorer 10 and above, then the UseRestrictedSecurity web.config setting can be set to 0 via IIS Manager on the Enterprise Vault server. To do this, expand the Default Web Site and select the Search virtual directory that is listed under the EnterpriseVault virtual directory. In the right hand pane open the Application Settings for the Search virtual directory and change the UseRestrictedSecurity option to 0. Please refer the "Configuring Enterprise Vault Search for use in Forefront TMG and similar environments" article in the Related Articles section of this article for more information.
Internet Explorer security zones registry entries for advanced users
Configuring Enterprise Vault Search for use in Forefront TMG and similar environments
- If DefaultWebAPP URL contain an ‘underscore’ then create EV server DNS alias from non-underscore DNS zone as it’s NOT recommended /Supported by Microsoft for Internet Explorer.
Internet Explorer blocks cookies from a server if the server name contains other characters, such as an underscore character ("_")
PRB: Session Variables Do Not Persist Between Requests After You Install Internet Explorer Security Patch MS01-055
How to change the DNS alias of the Enterprise Vault server
There are other possible causes for this error occurring, so further investigation is required if the steps above do not resolve the issue. Please contact Veritas Technical Support for assistance.