NetBackup 52x0 appliance upgrade to 2.6.0.1 fails/rolls back '- [Error] Failed to retrieve NetBackup storage units for'
Problem
NetBackup 52x0 appliance upgrade to 2.6.0.1 fails/rolls back, patch_log_2.6.0.1_* reports: '- [Error] Failed to retrieve NetBackup storage units for'
Error Message
Example log excerpts and command outputs:
/log/patch_log_2.6.0.1_MMDDYYHHMMSS_ROLLBACK/logs/iso/patch_log_2.6.0.1_MMDDYYHHMMSS reports:
[2014-01-14 04:21:09] The NetBackup daemons are online
[2014-01-14 04:21:09] Removing /upgrade volume...
[2014-01-14 04:21:09] /upgrade is mounted - removing it...
[2014-01-14 04:21:11] --- DONE
[2014-01-14 04:21:11] --- DONE
[2014-01-14 04:21:11] Removing upgvol....
[2014-01-14 04:21:11] --- DONE
[2014-01-14 04:21:11] Writing configuration information to CMDB...
[2014-01-14 04:21:11] Reloading nbappdb env...
[2014-01-14 04:21:11] Loading HWMon config to CMDB
[2014-01-14 04:21:13] --- DONE
[2014-01-14 04:21:13] Loading general config to CMDB
- [Error] Failed to retrieve NetBackup storage units for "AdvancedDisk" storage partition...
- [Error] Failed to retrieve NetBackup storage units for "MSDP" storage partition...
[2014-01-14 04:21:16] --- FAILED
[2014-01-14 04:21:16] RC=1
[2014-01-14 04:21:16] --- FAILED
[2014-01-14 04:21:16]
Upgrade failure detected - initiating rollback...
vxlogview -p NB -o 111 -d all, searched around the time of the upgrade reveals that an all uppercase hostname appears in a request to the master for storage unit information:
01/14/2014 04:21:15.184 [Diagnostic] NB 51216 nbemm 111 PID:18983 TID:139818034181888 File ID:111 [No context] 1 V-111-1061[StorageUnitImpl_3::ListStorageUnits_3] Client signature HOST=<SCO-NBMED01> VER=<760000> APP=<db_getSTUNITlist> PID=<21690>
01/14/2014 04:21:15.184 [Debug] NB 51216 nbemm 111 PID:18983 TID:139818034181888 File ID:111 [No context] 1 [StorageUnitImpl_3::ListStorageUnits_3] Master = SCO-NBMED01.r.acme.org
01/14/2014 04:21:15.209 [Debug] NB 51216 nbemm 111 PID:18983 TID:139818034181888 File ID:111 [No context] 1 [MachineObject::Exists] retval = 2000000
01/14/2014 04:21:15.209 [Application] NB 51216 nbemm 111 PID:18983 TID:139818034181888 File ID:111 [No context] [Error] V-111-1203 Master server SCO-NBMED01.r.acme.org not found
The /log/patch_log_2.6.0.1_011414042655_ROLLBACK/logs/iso/patch_log_2.6.0.1_011414012906 reports an uppercase hostname:
#################################
If this machine will be using a different network interface than the
default (SCO-NBMED01), the name of the preferred interface should be used
as the configured server name. If this machine will be part of a
cluster, the virtual name should be used as the configured server name.
The domainname of this machine appears to be ".r.acme.org".
You may choose to use this domainname in your configured NetBackup server
name, or simply use "SCO-NBMED01" as the configured NetBackup server name.
Would you like to use "SCO-NBMED01.r.acme.org" as the configured
NetBackup server name of this machine? [y,n] (y)
Is SCO-NBMED01.r.acme.org the master server? [y,n] (y)
Media servers can be added during this installation or
to a NetBackup environment after installation completes.
Refer to the NetBackup Administrator's Guide, Volume I for
more information.
Output of command 'hostname' or 'cat /etc/HOSTNAME' show that the real hostname is SCO-NBMED01 in all uppercase.
The NB appliance /usr/openv/netbackup/bp.conf 'SERVER =' list does not contain an entry for all upper case SCO-NBMED01 nor SCO-NBMED01.r.acme.org
Cause
If for example caps lock was on during initial appliance installation when typing the appliance hostname. But when the appliance configures NetBackup it typically uses lower case, then a mismatch is present between the /etc/HOSTNAME or 'hostname' command output and the bp.conf contents. The NetBackup appliance upgrade needs the case sensitive hostname to be present in the bp.conf file.
Solution
Veritas Corporation has acknowledged the above-mentioned issue (ETrack 3415664) is present in the current version(s) of the product(s) mentioned in this article. Veritas Corporation is committed to product quality and satisfied customers. This issue was scheduled to be addressed in the following release:
NetBackup 52x0 Appliances 2.6.0.2
When NetBackup Appliances 2.6.0.2 is released, please visit this link for download and README information:
https://go.Veritas.com/nba
Please note that Veritas Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Workaround:
Append the hostname of the appliance as shown by the output of the command 'hostname' as a new SERVER = entry in the /usr/openv/netbackup/bp.conf on the appliance. Save the file, rerun the upgrade.
Applies To
All of the following preconditions must be present for the issue to occur:
1. NetBackup (NB) 52x0 appliance version 2.5.1, 2.5.2, 2.5.3, or 2.5.4 upgrading to 2.6.0.1
2. Contents of affected NetBackup appliance /etc/HOSTNAME or output of 'hostname' command is a hostname not present in the NB appliance's /usr/openv/netbackup/bp.conf file as a SERVER = entry.